Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




108 posts

Master Geek
+1 received by user: 8


# 210269 20-Mar-2017 13:56
Send private message

Hi there

 

I've had a lot of help on a previous post regarding DLNA connectivity, and it has been suggested that I should post a new topic regarding Serviio.

 

The main problem is that although I can see my server through my Panasonic Bluray player, and can even drill down to see the files I want to play - hitting the play button leaves me with a 'cannot play' message.

 

A couple of the awesome guys trying to help me in the previous post suggested I try Serviio as my media server, which I have done.  Same problem with 'cannot play' when trying to stream the file through my bluray, but even worse, when I try to look at files in Serviio through another laptop (client) the message there is 'There are no items in this library'.  There are several files in that library, however.

 

Incidentally, when accessing Serviio (on my laptop as server) from husband's laptop (client), Serviio opens in Windows Media Player - don't know if that means anything?

 

When I access Serviio from the client by using the ip address, the client can stream away just fine.

 

All Bluray connectivity tests 'pass'.

 

Things I've tried:

 

* Turned off (temporarily) both Firewall and Security program.  Still no difference so presumably nothing to do with either of these blocking connectivity.

 

* Wondering if the problem could be due to incorrect pathways, I set up a file for test videos in the C Drive   C:\testVids     Still no luck 

 

 

 

Would anyone have any ideas please?

 

Thanks in advance


Filter this topic showing only the reply marked as answer Create new topic
2233 posts

Uber Geek
+1 received by user: 457

Lifetime subscriber

  # 1744543 20-Mar-2017 14:37
2 people support this post
Send private message

Windows Media Player is NOT DLNA compliant so will not work. Use Kodi or VLC.

 

As for the Panasonics, update their firmware.





Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


8448 posts

Uber Geek
+1 received by user: 2891

Lifetime subscriber

  # 1744632 20-Mar-2017 16:46
One person supports this post
Send private message

Right here is what mine looks like in windows 10.

 

In windows explorer when the serviio server has been setup and is running i see this (Click to make the images bigger):

 

Click to see full size

 

from there i can either use the small link on the Left hand side or the large one under "This PC", they both go to the same place, from there i can open the different catogories and use what ever media player i like on the PC to view the video/music files.

 

This is a screen shot of my Status page, make sure "Enable access for new devices" is checked and that the server is running, you should see any devices that try to connect to the server in the top section (you can see 2 in my image) and using the edit button you can change the profile of the device if the media doesnt play properly. 95% of the time generic works. i have a different one set for my freevied decoder as it didnt like some media for some reason. but there are panasonic profiles listed you could try.

 

Click to see full size

 

In the library tab you need to make sure you add the folders you want to share, then i would make sure these are ticked : "Keep library automatically updated" and "Search for updates of currently shared files"

 

Click to see full size

 

also make sure in the delivery tab you have enabled transcoding (this changes the format of some files that it normally wouldn't be able to play to one that it can) make sure it has a directory for temp files and select your quality type you want, i have mine set to optimal and produce best video quality.

 

thats all you should need to do on the server end. you device you should be able to go to the media player or uPnP client and find the serviio server then browse the folder structure as you would in windows then select a file then play it.

 

as mentioned make sure you have the latest firmware on the TV and Bluray

 

 


 
 
 
 




108 posts

Master Geek
+1 received by user: 8


  # 1744647 20-Mar-2017 17:18
Send private message

Hello again Jase

 

Thanks for putting so much time into this post for me.

 

I'll go through everything and make sure I have everything as per your screen shots and advice.  

 

On your status page it looks like you're using Windows Media Player, which is what Panasonic say to use.  But I've been told, and read elsewhere, the WMP isn't DLNA compliant.  So I've been trying to use VLC instead and finding it a bit difficult to follow how to set up.  If you are finding it okay with WMP perhaps I'll try to struggle on with that for a bit in the meantime.

 

Thanks again.  I'll let you know how I get on.

 

PS:  Panasonic Firmware is up to date  :-)


8448 posts

Uber Geek
+1 received by user: 2891

Lifetime subscriber

  # 1744658 20-Mar-2017 17:40
Send private message

The 2 IP's you see there are both PC's so thats why its saying WMP. Using the TV or Bluray it will say something different, My TV says LG TV next to it.

 

the only time you should be using windows media player or VLC is to play media on a computer as in the first image it just opens the serviio folder structure in windows explorer and you can use what ever media player program you have on your computer to play the media. but thats completely different to using the TV/Bluray

 

what model TV and Bluray do you have? are they up to date with the latest firmware?




108 posts

Master Geek
+1 received by user: 8


  # 1744681 20-Mar-2017 17:54
Send private message

WOO HOOOOOO!!

 

Thanks so much for all your help Jase for all your help throughout both posts, and Spyware thanks - you held the final key by suggesting I should use VLC instead of WMP.

 

I did as you said Jase by changing the different categories (video/music/etc) to use VLC (rather than the original WMP I had been using) on the PC to view the video/music files.

 

Now it works!!  

 

Well, that was a challenge!  I could not have come anywhere near getting this going without you guys  :-)

 

Thanks again.

 

 


8448 posts

Uber Geek
+1 received by user: 2891

Lifetime subscriber

  # 1744715 20-Mar-2017 18:41
Send private message

 

now it works? on the laptop? does it work on the TV/Bluray?

 




108 posts

Master Geek
+1 received by user: 8


  # 1744725 20-Mar-2017 18:55
Send private message

Yes  :-)  It works on the Bluray.  Still can't see my Serviio files on my husband's computer but I'm working on that at the moment.  Main thing is, it runs beautifully on the bluray.

 

 

 

Hurrah!

 

 

 

Time for a wine ... or 2!!




108 posts

Master Geek
+1 received by user: 8


  # 1744805 20-Mar-2017 20:41
Send private message

I forgot to say that I also changed the profile from 'Generic DLNA Profile' to 'Panasonic BD Player' so this may also have contributed to the resolution.  :-)


Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Video game market in New Zealand passes half billion dollar mark
Posted 24-May-2019 16:15


WLG-X festival to celebrate creativity and innovation
Posted 22-May-2019 17:53


HPE to acquire supercomputing leader Cray
Posted 20-May-2019 11:07


Techweek starting around NZ today
Posted 20-May-2019 09:52


Porirua City Council first to adopt new council software solution Datascape
Posted 15-May-2019 12:00


New survey provides insight into schools' technology challenges and plans
Posted 15-May-2019 09:30


Apple Music now available on Alexa devices in Australia and New Zealand
Posted 15-May-2019 09:11


Make a stand against cyberbullying this Pink Shirt Day
Posted 14-May-2019 20:23


Samsung first TV manufacturer to launch the Apple TV App and Airplay 2
Posted 14-May-2019 20:11


Vodafone New Zealand sold
Posted 14-May-2019 07:25


Kordia boosts cloud performance with locally-hosted Microsoft Azure ExpressRoute
Posted 8-May-2019 10:25


Microsoft Azure ExpressRoute in New Zealand opens up faster, more secure internet for Kiwi businesses
Posted 8-May-2019 09:39


Vocus Communications to deliver Microsoft Azure Cloud Solutions through Azure ExpressRoute
Posted 8-May-2019 09:25


Independent NZ feature film #statusPending to premiere during WLG-X
Posted 6-May-2019 22:13


The ultimate dog photoshoot with Nokia 9 PureView #ForgottenDogsofInstagram
Posted 6-May-2019 09:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.