Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


ageorge

477 posts

Ultimate Geek


#275765 8-Sep-2020 12:50
Send private message quote this post

Greetings.

 

I set up port forwarding as explained in various places, but checking the port shows its still closed.

 

I suspect the IP address, but Ive used as shown and 192.168.20.100 with Ubuntu IFconfig to find WAN port and also used WAN port under info in the NFV18ACV dialogs.

 

I dont understand the process, just following guides, but need help if anyone can suggest what could be stopping port forwarding from working?

 

 

 

 

 

I can open the ports with access control, but thats not the correct method:

 

 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
freitasm
BDFL - Memuneh
68831 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  #2560261 8-Sep-2020 13:01
Send private message quote this post

What you have done on the second screenshot is open up your router to the world. I suggest you revert those changes now.




 

 

These links are referral codes

 

Geekzone broadband switch | Eletricity comparison and switch | Hatch investment (NZ$ 10 bonus if NZ$100 deposited within 30 days) | Sharesies | Mighty Ape | Backblaze | Coinbase | TheMarket | My technology disclosure


ageorge

477 posts

Ultimate Geek


  #2560264 8-Sep-2020 13:04
Send private message quote this post

freitasm: What you have done on the second screenshot is open up your router to the world. I suggest you revert those changes now.

 

I can open the ports with access control, but thats not the correct method!


 
 
 
 


taneb1
437 posts

Ultimate Geek

Trusted
Trustpower

  #2560265 8-Sep-2020 13:05
Send private message quote this post

What type of internet connection do you have ADSL/VDSL or UFB?





Any comments made are my personal views and does not represent those of my employer


ageorge

477 posts

Ultimate Geek


  #2560267 8-Sep-2020 13:10
Send private message quote this post

taneb1:

 

What type of internet connection do you have ADSL/VDSL or UFB?

 

 

UFB

 

I just went to my network PC settings and got my IPV4 address as 192.168.20.9 but thats not doing it either.


taneb1
437 posts

Ultimate Geek

Trusted
Trustpower

  #2560282 8-Sep-2020 13:17
Send private message quote this post

Okay, so if you access it internally it is on https://192.168.20.9 ? I would possibly try use a different external port start/end instead of 443 and see if that works instead. 





Any comments made are my personal views and does not represent those of my employer


ageorge

477 posts

Ultimate Geek


  #2560284 8-Sep-2020 13:19
Send private message quote this post

taneb1:

 

Okay, so if you access it internally it is on https://192.168.20.9 ? I would possibly try use a different external port start/end instead of 443 and see if that works instead. 

 

 

Been there, done that, not work


taneb1
437 posts

Ultimate Geek

Trusted
Trustpower

  #2560285 8-Sep-2020 13:21
Send private message quote this post

So just confirming it is https://192.168.20.9 you use if you access it internally? Might be worth contacting Netcomm Support directly. 





Any comments made are my personal views and does not represent those of my employer


 
 
 
 


ageorge

477 posts

Ultimate Geek


  #2560287 8-Sep-2020 13:22
Send private message quote this post

As I understand it:

 

alistair@alsmain:~$ ip r
default via 192.168.20.1 dev enp1s0 proto dhcp metric 100 
169.254.0.0/16 dev br-fcb5695d0a8b scope link metric 1000 linkdown 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
172.18.0.0/16 dev br-fcb5695d0a8b proto kernel scope link src 172.18.0.1 linkdown 
192.168.20.0/24 dev enp1s0 proto kernel scope link src 192.168.20.9 metric 100 

 

My default gateway is 192.168.20.1 so any IP in forwarding should work thusly: 192.168.20.100 and so on correct?

 

If correct, what could possibly be the problem?

 

Thanks.

 

Al.


ageorge

477 posts

Ultimate Geek


  #2560294 8-Sep-2020 13:24
Send private message quote this post

taneb1:

 

So just confirming it is https://192.168.20.9 you use if you access it internally? Might be worth contacting Netcomm Support directly. 

 

 

Netcomm are overseas based and unlikely to spend phone time with an unknown user.

 

I did phone up my ISP Slingshot first, and they have no idea about port forwarding (or so their operator said)

 

Maybe I need to change to a cheaper ISP ;-)


noroad
629 posts

Ultimate Geek

Trusted

  #2560300 8-Sep-2020 13:36
quote this post

So you are trying to allow public access to an internal server on 192.168.20.9 port 443 ? Firstly as people have suggested you need to confirm you can internally access that. People have asked if you can get to https://192.168.20.9 internally, if you can not do that then its nothing to do with your port forward, go back to the server and work out why before continuing. I would suggest you need to open up the firewall on the server. Do NOT do this unless you are properly patching it. Secondly you can not have a port forward to a port that you are using on your management/access control. You show samba (just no!) on port 443 so that will not work. change the samba port to something random and disable it. It is only safe to enable ICMP (do this) on the wan, never enable anything else unless you really understand what you are doing. Your port forward itself looks fine, just fix those other two things.


ageorge

477 posts

Ultimate Geek


  #2560305 8-Sep-2020 13:44
Send private message quote this post

noroad:

 

So you are trying to allow public access to an internal server on 192.168.20.9 port 443 ? Firstly as people have suggested you need to confirm you can internally access that. People have asked if you can get to https://192.168.20.9 internally, if you can not do that then its nothing to do with your port forward, go back to the server and work out why before continuing. I would suggest you need to open up the firewall on the server. Do NOT do this unless you are properly patching it. Secondly you can not have a port forward to a port that you are using on your management/access control. You show samba (just no!) on port 443 so that will not work. change the samba port to something random and disable it. It is only safe to enable ICMP (do this) on the wan, never enable anything else unless you really understand what you are doing. Your port forward itself looks fine, just fix those other two things.

 

 

Re the samba - I repeat that was only used as a test and its port is actually 442 and its disabled by default. The reason for using it modified to 443, was to ascertain if the port was able to be accessed by my default gateway.

 

 

 

Port forward to 192.168.20.100 should be fine. I will check as you suggest what might be blocking it thanks.

 

Al.


djtOtago
678 posts

Ultimate Geek

Subscriber

  #2560308 8-Sep-2020 13:52
Send private message quote this post

So what computer on your internal network has the IP address 192.168.20.100 and what service does it have that is listening on port 443


ageorge

477 posts

Ultimate Geek


  #2560309 8-Sep-2020 13:53
Send private message quote this post

OK if I turn off the firewall in Netcomm NFV18ACV then the port forward works. So thats the culprit. Wonder how I can have my firewall enabled, but still port forward.

 

 

 

The above is wrong, all ports are forwarded if the firewall is turned off.


ageorge

477 posts

Ultimate Geek


  #2560316 8-Sep-2020 14:05
Send private message quote this post

djtOtago:

 

So what computer on your internal network has the IP address 192.168.20.100 and what service does it have that is listening on port 443

 

 

ip r:

 

default via 192.168.20.1 dev enp1s0 proto dhcp metric 100 

 

Am I wrong assuming that any range in 192.168.20.?? should reach as per original post?


djtOtago
678 posts

Ultimate Geek

Subscriber

  #2560322 8-Sep-2020 14:15
Send private message quote this post

192.168.20.100 will work, But there has to be something on your internal network with that IP address. Otherwise you are just forwarding to nothing.


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.