Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

12 posts


Topic # 2200 8-Sep-2004 07:35 Send private message

This is a small guide for those who installed the Service Pack 2 for Windows XP and are
experiencing problems with the WIDCOMM Bluetooth software..

If you install the WIDCOMM BTW Bluetooth software on Windows XP SP2, you will get the following error as soon as you double click on the blue-red system tray icon:

"Your Bluetooth Software license does not include use with this Bluetooth Device"

After that you will be asked to point to a valid license.dat file. However if you select the
license.dat that came with your manufacturer's driver (be it on CD-ROM or downloaded from
the manufacturer's website) it still won't work.

The reason for this problem:

In the Service Pack 2, Microsoft included a generic Bluetooth driver, naturally being
WHQL-certified -- it's directly from Microsoft. The WIDCOMM Bluetooth driver however is not
WHQL-certified, so Windows XP continues using the generic driver. This interferes with the
WIDCOMM Bluetooth software resulting in the above error.

To force Windows XP to use the WIDCOMM driver, perform the following steps:

Don't plug in the Bluetooth device yet.

If you have any Bluetooth software apart from the included Windows drivers installed, deinstall
them and reboot. I am not sure if this is necessary, but just in case.

Install the WIDCOMM BTW Bluetooth software. When it asks you to plug in the
Bluetooth device and click OK, don't, and click cancel instead.

When the WIDCOMM setup has finished, plug in your Bluetooth device and let Windows install
the driver. (There should be two Bluetooth icons in the system tray; one blue-white: this is the Windows driver - and one blue-red: this is the WIDCOMM driver which is deactivated.)

Now go to the Device Manager, right click on the "Generic Bluetooth Radio" and select "update
driver". Don't let Windows XP connect to the internet, then select "Choose software from a list or specified location". In the next window, select "Don't search, but select the driver to install".

In the next window, activate "Show compatible hardware" (if it isn't activated already) and
select your manufacturer's driver instead of the "Generic Bluetooth Radio" driver.

Click next until the new driver is installed. Now the WIDCOMM system tray icon should be
blue-white as well, activated and ready to use.

If you now double click on "My Bluetooth Places" (e.g. on the desktop), the WIDCOMM software installation will be continued and finished.

This should solve any compatibility issues with the WIDCOMM BTW Bluetooth software and Microsoft Windows XP SP2.

If you still experience problems, please reply to this thread. If necessary, I will update this
HowTo accordingly.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3
9 posts

Wannabe Geek

Reply # 8352 8-Sep-2004 12:19 Send private message

You have explained exactly what happened to me when I replaced the windows driver with my Belkin (widcomm) drivers. I got the message "Your Bluetooth Software license does not include use with this Bluetooth Device [6]."

I have not tried exactly what you said because Belkin is recognized by windows. So if I followed your instructions installing the Belkin (widcomm) software without the dongle plugged in and waited for the appropriate time to plug it in windows will immediately recognize the new hardware and install their drivers. I do not have the chance to install a generic bluetooth device.

How can I get windows from immediately installing its version of a Belkin driver (certified)? When I update the driver in device manager then I get the license violation. At least that is what happened to me when I installed Belkin software with the dongle plugged in and the driver updated to the Widcomm driver.

I will now try what you said, but I do not have any hope.

9 posts

Wannabe Geek

Reply # 8355 8-Sep-2004 14:17 Send private message

Well I did just what you said with one addition XP was adding the devices so fast I deleted the Microsoft Environmental Device (or what ever the name is of the two bluetooth devices XP installs) Then I changed the driver of the Belkin device to the Widcomm drivers and everything seemsed to go very well.

Now my Belkin recognizes my phone, but I cannot get SonyEricsson's Dial Up Networking to recognize the phone (T616). Actually it did recognize it once, but it seemed to be setting up a lot of stuff I did not need I really do not want to establish nework connections on my phone. Also I cannot get the XTND software to recognize the phone. I do have my Belkin connecting to the phone via Serial Port. But still no XTND.

any hints



12 posts


Reply # 8361 8-Sep-2004 19:21 Send private message

You do not have to keep Windows from installing any driver. It doesn't matter *which* driver Windows installs, it's about the fact *that* it installs any driver *but* the WIDCOMM driver.

If Windows doesn't recognize the Bluetooth device, it'll install the generic driver. If the device is recognized (like with your Belkin), it'll install the more appropriate (i.e. Belkin) driver.

However you still want the WIDCOMM driver. So install the WIDCOMM software, on the point where you're asked to plugin your Bluetooth device just don't and press cancel, finish the installation.

Then plug in the Bluetooth device, and let Windows install the driver it wants to install (be it "Generic Bluetooth Radio" or "Belkin" or whatever).

After this has happened, go to the Device Manager and perform the steps above.

I hope this helps. I'm not sure though because I haven't had this problem. Please be sure to check in again and report your success (if you have any).

9 posts

Wannabe Geek

Reply # 8387 9-Sep-2004 05:25 Send private message

Well yesterday I got the dongle to work and paired with my T616 but XTND would not work. Today it did. I was able to use the hint given by David Hettel on how to get rid of the excess baggage of previous plug in and outs of the bluetooth dongle. I am up to port 21, but I do not think I will try it again to see if I will get a lower port number, if it works don't break it.

By the way I could not get by with just enabling ports 1, 19, 20, 21, 22, & 23 to get XTND to work. I enabled all ports from 1 through 23 (last one listed) and only then did it recognize the phone.

I enabled Dial Up networking although I will never use it with my T616, but my experiencee is unless Dial up networking recognizes the phone then XTND will not either. According to the article about using SonyEricsson software on Geekzone there is a program called Phone settings in the SonyEricsson group, but mine only has dial up networking in the group.

Thanks for your help, you seem to be the only one that understands the problem and the solution.

1 post

Wannabe Geek

Reply # 8852 25-Sep-2004 05:18 Send private message

Did the above steps but still having trouble with Nokia PC Suite recognizing the bluetooth drivers. When I originally installed PC Suite pre SP2 everything worked fine. Installed SP2 and before reading this thread had difficulty. So after many long phone calls with various tech support lines, I resorted to doing a fresh install of WinXP without SP2 and that is where I stand now. Device manager show that WIDCOMM is the driver. Any suggestions?


11 posts


Reply # 8853 25-Sep-2004 06:40 Send private message

So, I was on these forums a few months back complaining about a Logitech dinovo setup which was dying left, right and center. Turned out to be the motherboard's VIA USB setup. A USB card sorted that out.

I now have a Asus A7N8X-E Deluxe motherboard, running WinXP Pro and decided to slap on the SP2 because of the hype about its firewalling and the bluetooth support.

Today I have to check out a bluetooth device from MSI. I've been running my dinovo bluetooth hub as is, no software installed, because I'm waiting for a replacement keyboard to arrive and just use the mouse now.

Anyway, now I see getting the Widcomm stuff installed is a pain in the butt with SP2.

I have installed Widcomm before installing the device, then installed the drivers for the new MSI BToes device. The device shows in the USB section of the device manager. There's no section for bluetooth stuff as was the case in Win2K with dinovo setup.

I then proceeded to follow the instructions listed here. But where is this "Generic Bluetooth Radio"?

Does SP2 place the bluetooth icon on the system tray by default? I only get the Widcomm item.

Odd thing is, I got this kind of running on XP + SP2 at someone's office today, but then it gave up and I sat with the same problem I have here at home.

Plugging in my dinovo hub and going through the Logitech SetPoint driver/software installation eventually puts up a popup indicating that there is already a bluetooth stack installed on this machine and it will not install the widcomm stuff which will result in the fantastic Logitech hub only being used for the keyboard and mouse combination. That sux.

Any smooth solutions to this bluetooth issue in SP2? I'm still confused as to why I don't have a bluetooth control panel like some people indicate. Trying to start up bthprops.cpl results in nothing. At one point it just said I didn't have a bluetooth device attached, but usually it does nothing.

I even change the VID&PID in the ".inf" file for widcomm to match the specifics of the MSI device and still nothing works.

But let me guess... the bluetooth stack provided in SP2 works 100% perfectly fine with any bluetooth wireless Microsoft keyboard & mouse, right?

BDFL - Memuneh
57904 posts

Uber Geek
+1 received by user: 9510


Reply # 8854 25-Sep-2004 10:07 Send private message

It's my opinion, expressed in other postings that if you have a Widcomm based solution stick with it - don't use the Windows XP Service Pack 2 Bluetooth stack.

Next, no, the icon is not there automatically. You have to open the Control Panel and check a box to make the icon show up.

There are instructions on how to use the Widcomm driver instead of the Windows one. One option is to install the Widcomm based software, reboot, then find the Bluetooth device in the Hardware Settings and manually change the driver. That should do it.


11 posts


Reply # 8859 25-Sep-2004 11:18 Send private message

And where exactly does one find that checkbox to click?

So I have managed to get the Logitech stuff to install and finally show up the "Bluetooth device" in the device manager. It reckons the manufacturer is widcomm. However, this doesn't help much with the MSI BToes dongle.

BDFL - Memuneh
57904 posts

Uber Geek
+1 received by user: 9510


Reply # 8860 25-Sep-2004 11:27 Send private message

The checkbox to show the Bluetooth SP2 icon is the Control Panel, Bluetooth.

Why did you install the Logitech software if you want to use the MSI? Does the MSI software support HID (in other words, is it version 1.4 or up)? If yes, then you could use that one, since mouse and keyboard will work, regardless of manufacturer.

You can have two Bluetooth stacks running in parallel, don't even think of three (Logitech, MSI and Microsoft). You'll have to use one, and if the MSI supports everything you need, use this.

I think there are too many files around now...


11 posts


Reply # 8863 25-Sep-2004 12:04 Send private message

Yeah, probably too many files. :)

Anyway, it's running. Seems widcomm is installed along with the logitech hub. That's my normal setup for this machine. The MSI is only on loan for testing to see if it can run with SP2. So far, no luck. Uses widcomm drivers too.

Seems the widcomm is running on this machine now. Pulled out the logitech hub, installed Setpoint, skipped the routine where it says there is no device, then rebooted it with the hub back in place. Installed the drivers fine. Seems to be running now. No bluetooth taskbar icon, but bluetooth places is on the desktop. Haven't searched for my cellphone yet, so not sure if this is now limited to the logitech devices only (as indicated by logitech if not using the widcomm stuff).

Tomorrow when I have time I'll reboot and pop in the MSI device and see if it installs correctly. It's 2am, can't be bothered with it now.


11 posts


Reply # 8893 26-Sep-2004 06:16 Send private message

URh... I removed widcomm and logitech setpoint. Seems everytime I boot up I have to go through device installation. No time for it now. I'm going to run your procedure above to see if I can get the MSI to come up as a BT device as opposed to some generic USB thing.

Thanks. :)

2 posts

Wannabe Geek

Reply # 8925 27-Sep-2004 15:22 Send private message

I have a similar type of problem with Bluetooth driver and Belkins Bluetooth Printer Adapter.
I loaded the SP2, now I can get Bluetooth to work with my BT Adapter and printer, but after like one or two days I lose connectivity. The only way to get it back is to go to a restore point where it worked and reload. Once I do that it will again work for a couple of days and gone again?? This always happens when I reboot or use Hibernate. One I lose power, the drivers are gone. I downloaded the driver from Dell for the Bluetooth Module. The Belkins Adapter for the printer did not require any software installation?
When printintg and on the wireless broadband, I now get a lock up. I have to clear the printer and restart to get things working again.
I think it may have somethng to do with Power Mgt??
I could sure use some advise??

BDFL - Memuneh
57904 posts

Uber Geek
+1 received by user: 9510


Reply # 8932 27-Sep-2004 17:45 Send private message

Do you have reboots during these two days periods when the device connect ok? Is the Bluetooth connected to a USB HUB?

3 posts

Wannabe Geek

Reply # 9015 30-Sep-2004 06:22 Send private message

I have an MSI KT3 Ultra2 motherboard with Bluetooth. I got the same error "Your Bluetooth Software license does not include use with this Bluetooth device. [6]."

I've tried the solution about uninstalling, rebooting, and reinstalling with out device plugged in, then plugging it in, then pointing the drivers directly to correct WIDCOMM path. And updating driver and pointing to the correct path, but it still doesn't work.

Also, I don't see the "General Bluetooth Radio" in my device manager, but what I see is "MSI USB Bluetooth Device." And I don't the the second Bluetooth icon appear in the system tray as described in the solution post.

After I click on the "OK" button from the "Your Bluetooth Software license does not include use with this Bluetooth device. [6]" it wants to find the license.dat file, and I point it to the installation folder for the WIDCOMM drivers where the license.dat file is, but nothing happens.

Also, the old software 1.2.2x works, but when upgrading to the newer drivers I get this problem.

I'd really appreciate some help on this. Thanks.

BDFL - Memuneh
57904 posts

Uber Geek
+1 received by user: 9510


Reply # 9018 30-Sep-2004 07:43 Send private message

Antoniost, are you using the drivers supplied by MSI, or some other company's drivers?

 1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

New Zealand government secures cloud framework agreement with Amazon Web Services
Posted 30-May-2017 15:51

Mobile termination rate revision not pressing
Posted 30-May-2017 15:16

IBM remote work recall a red herring
Posted 29-May-2017 19:15

RBI2 bidders at Rural Connectivity Symposium
Posted 29-May-2017 12:50

Edifier R1700BT speakers review: Luxury Bluetooth sounds
Posted 28-May-2017 13:06

National AI group launching next month
Posted 25-May-2017 09:54

New Zealand Digital Future, according to tech companies
Posted 25-May-2017 09:51

New Microsoft Surface Pro delivers outstanding battery life, performance
Posted 25-May-2017 09:34

Garmin VIRB 360 brings immersive 360-degree 5.7K camera experience
Posted 25-May-2017 09:30

Telecommunications monitoring report: Are you being served?
Posted 24-May-2017 11:54

NetValue partners with CRM Provider SugarCRM
Posted 23-May-2017 20:04

Terabyte looms as Vocus users download 430GB a month
Posted 19-May-2017 14:51

2degrees tips into profit after seven lean years
Posted 19-May-2017 09:47

2degrees growth story continues
Posted 17-May-2017 15:25

Symantec Blocks 22 Million Attempted WannaCry Ransomware Attacks Globally
Posted 17-May-2017 12:41

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.