I found a guide and their is a gotcha with the Telecom version of the software as they have changed the default preconfigured LPR queue name to "TG582Printer" in the guide is is set to "Printer" all you need to do is use this name when configuring the LPR port queue name and you should be good to go.

Guide found here.
beusergroup.co.uk/technotes/index.php?title=Printer_sharing_TG582n

The default IP address 192.168.1.253 is correct, but this can be changed via the command line if you flush the DHCP leases and establish a new reservation for the LPD you can then set it to whatever you want.

I also changed the LPR Queue name to "Brother" on my router while i was at it..

You can check what the queue name is and the IP address of the print server via telnet. If you don't like the cli you can type menu and you get a basic ascii navigate-able menu.

Telnet 192.168.1.254
user/pass

printersharing LPD list
LPD printserver service:
    enable: 1

printersharing LPD queue list
LPD queue info:
    name: brother
    type: Raw
    default: 1

dhcp server lease list
Lease                Pool            TTL           State     Clientid
192.168.1.253     LAN_private     infinite      USED      [01] 5a:98:35:a5:6e:00

It would have been nice if telecom had a guide up on how to use this feature on their router.