I'm using a Telecom-supplied W705a with firmware R1FA035. Under Settings > Connectivity > USB, I've set the "USB data account" to TelecomData (direct.telecom.co.nz). The same change automatically applies under Bluetooth (the two seem to be linked).

When I tether to my laptop using either USB or Bluetooth, it doesn't use that APN. A visit to checkip.dyndns.org shows that I'm sitting behind the Telecom proxy farm and am therefore using one of the "normal" APNs instead. If I open checkip.dyndns.org on the phone itself (with TelecomData selected under Settings > Connectivity > Internet Settings), then it returns a public address.

It seems that no matter what I do, the phone will always use TelecomContent when tethering. This has not always been a problem, and I think it began after I updated to firmware R1FA035 (I'm not sure what version I had before that). Can anyone offer any assistance?

Thanks :)