I'm still trying to set up a Raspberry Pi as an HTPC. It's a learning experience. This isn't my first post on the subject.

The most recent difficulty: I'm struggling to get TVheadend 4.0.5 to work with Freeview. This is the version bundled with the latest version of OSMC. I've played with both OSMC and OpenELEC and prefer the fact that OSMC has a full-blown OS under the hood that let's me play around with other stuff too.

While I was still experimenting (pre-OSMC install), I managed to get TVheadend 3.9 going (following @tarlen's awesome instructions here). But something is eluding me in the later version.

So far I've (all under config --> DVB inputs):

1. Networks --> Add to create a new DVB-T network named "Freeview" 
2. TV adapters --> my DVB-T card, tick enabled, assigned to Freeview network
3. Muxes --> Add. I've used both the pre-defined muxes (under Networks) and custom muxes. For the custom muxes, I followed @tarlen's instructions and left everything except bandwith set to auto, and bandwidth to 8.
4. Networks --> Select "Freeview" --> Force scan

It took a bit of fiddling to even get the scan queue running, but even when I did get it to run, no services showed up.

I'm in Wellington (Mt Kaukau) and have made sure I used the new(ish) frequencies (562, 578 & 594 MHz - and remembered to include the trailing 000s).

For most of the optional settings (e.g. ignore provider channels, idle scan etc.) I've tried flicking things on and off, but obviously haven't hit on the right combination.

I'm sure I'm missing something small and/or obvious.

Would someone mind posting their config settings?