This is a question for the one geek in NZ who knows this stuffSmile.

I have an unencrypted blu-ray VC-1 video here, as well as an unencrypted h.264 video.  I ripped both videos to my HTPC hard drive so I could play them in MediaPortal.

I remuxed the m2ts files to .ts files which is what MediaPortal supports.  The h.264 video plays fine, but the VC-1 video crashes the software.

Someone discovered a solution on another forum to simply rename the VC-1 file to .ts.wmv.  This now plays in MP and other apps.

However, when playing the h.264 video, my CPU is less than 10%, but the VC-1 video is around 50%.  It appears the VC-1 video is not utilising hardware accelleration.

My HTPC has an 780G/HD3200 ATI gfx with Cyberlink PowerDVD 8 installed,  Playing the VC-1 video in Cyberlink also uses 10% or less so is using hardware acceleration.

I think the issue may be the DirectShow filters being used.  I installed software called GraphStudio which shows the DirectShow decoders being used for specific media files.  The VC-1 video shows it is using the WMVideo decoder DMO.

Using RadLight Filter Manager, I can see Cyberlink provides a VC-1 decoder, but this is not being used.  I tried increasing the Merit value of this codec so it was preferred over the WMVideo decoder, but it still doesn't use it.

is there some way of forcing the Cyberlink VC-1 decoder filter to be used by default.  perhaps I need to use a different file extension?

Hopefully someone can help.