Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


logo

568 posts

Ultimate Geek

Trusted

#288605 11-Jul-2021 22:28
Send private message

Hi all

 

 

 

I have a TCL 55E17NUS which I bought in Dec 2017, so 3.5 years old.

 

 

 

Often the screen will go black - actually the backlight switches off as you can still, very faintly see the images if you look close enough. Everything else works fine, sound, menus etc... The only way to fix it is to turn the TV off and back on again.

 

 

 

Usually I would say the LED backlighting is faulty however this fault only appears when I switch to the TV. I can run netflix or stream through the chromecast for hours on end and the TV runs fine. Within seconds of switching to TV the screen goes black. Maybe the TV tuner is drawing more power which causes the fault idk.

 

 

 

I've hard reset the TV, unplugged it and done all the usual stuff to no avail. Right now I've switched off tv antenna input and just streaming everything.

 

 

 

I'm a little annoyed as the TV is just out of it's 3 year warranty period - although I may have grounds under the CGA (https://www.consumer.org.nz/articles/4-year-old-tv-stops-working)

 

 

 

I'm hoping (but note expecting) this is a software issue. Maybe I should try and downgrade the firmware. 

 

 

 

Plan B is the TV goes into the mancave which doesn't have an aerial socket so everything will be streaming anyway but I would rather this be sorted. 

 

 

 

 

 

 

 

 

 

 


Create new topic
Affiliate link
 
 
 

Affiliate link: Trade NZ and US shares and funds with Sharesies.
robjg63
3482 posts

Uber Geek


  #2742854 12-Jul-2021 08:29
Send private message

When you say 'hard reset' , you mean like a factory reset?
Sounds like an annoying fault - definitely push for a fix/replacement.




Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler


Batman
Mad Scientist
27808 posts

Uber Geek

Trusted
Lifetime subscriber

  #2742858 12-Jul-2021 08:43
Send private message

do a reset to factory settings and see





Involuntary autocorrect in operation on mobile device. Apologies in advance.


johny007g
267 posts

Ultimate Geek


  #2761464 17-Aug-2021 15:00
Send private message

Hi @logo was wondering if you ended up with solution to your problem as i have exactly the same problems with the same TCL 55EN17NUS model, also out of warranty 3 years in March and calling support goes round in circles with no solution. Did you have to get it repaired or was it software problem as when I last had problems support gave me updated firmware which seemed to fix everything and happy with TV then. This is such a pain as just so random and watching TV program and then no picture just sound varies between 10 mins to 30 mins ,and need to turn TV off and on to continue but watching through app ok at least 5 hour's 
Saturday was able to watch sport and all blacks, TVNZ app same had on today so far 7 hours, but android box on HDMI same random blackouts.





johny007g



logo

568 posts

Ultimate Geek

Trusted

  #2761801 17-Aug-2021 19:59
Send private message

johny007g:

 

Hi @logo was wondering if you ended up with solution to your problem as i have exactly the same problems with the same TCL 55EN17NUS model, also out of warranty 3 years in March and calling support goes round in circles with no solution. Did you have to get it repaired or was it software problem as when I last had problems support gave me updated firmware which seemed to fix everything and happy with TV then. This is such a pain as just so random and watching TV program and then no picture just sound varies between 10 mins to 30 mins ,and need to turn TV off and on to continue but watching through app ok at least 5 hour's 
Saturday was able to watch sport and all blacks, TVNZ app same had on today so far 7 hours, but android box on HDMI same random blackouts.

 

 

 

 

I went back to the retailer (JB Hifi) and quoted the CGA. Had a robust discussion as to how long I should expect the TV to last given I only paid $800 for it (answer was longer than 3.5 years) and they agreed to get it looked it. 

 

Dropped it off at JB and they sent it to Tisco. TCL advised they didn't have any parts for it anymore and offered me a refurb (same model) for $250 (inc GST) plus delivery. Tisco had a $118 inspection fee but JB had agreed to pick up the tab for that. I just wanted a working tv back without paying anymore but we were at a stalemate. I then realised that I get my old TV back as well and that is working fine except for the TV tuner problem. As I was wanting a TV for my mancave which doesn't have an aerial anyway so I decided to go for the deal.

 

 

 

So cost me $274 (inc delivery) for a refurb model with 1 year gtee and I have my old TV to use in my mancave. 

 


Was hoping to get it this week but will have to wait until next week now (damn you covid!)

 

 

 

 

 

 

 

 


johny007g
267 posts

Ultimate Geek


  #2762611 18-Aug-2021 16:32
Send private message

logo:

 

johny007g:

 

Hi @logo was wondering if you ended up with solution to your problem as i have exactly the same problems with the same TCL 55EN17NUS model, also out of warranty 3 years in March and calling support goes round in circles with no solution. Did you have to get it repaired or was it software problem as when I last had problems support gave me updated firmware which seemed to fix everything and happy with TV then. This is such a pain as just so random and watching TV program and then no picture just sound varies between 10 mins to 30 mins ,and need to turn TV off and on to continue but watching through app ok at least 5 hour's 
Saturday was able to watch sport and all blacks, TVNZ app same had on today so far 7 hours, but android box on HDMI same random blackouts.

 

 

 

 

I went back to the retailer (JB Hifi) and quoted the CGA. Had a robust discussion as to how long I should expect the TV to last given I only paid $800 for it (answer was longer than 3.5 years) and they agreed to get it looked it. 

 

Dropped it off at JB and they sent it to Tisco. TCL advised they didn't have any parts for it anymore and offered me a refurb (same model) for $250 (inc GST) plus delivery. Tisco had a $118 inspection fee but JB had agreed to pick up the tab for that. I just wanted a working tv back without paying anymore but we were at a stalemate. I then realised that I get my old TV back as well and that is working fine except for the TV tuner problem. As I was wanting a TV for my mancave which doesn't have an aerial anyway so I decided to go for the deal.

 

 

 

So cost me $274 (inc delivery) for a refurb model with 1 year gtee and I have my old TV to use in my mancave. 

 


Was hoping to get it this week but will have to wait until next week now (damn you covid!)

 

 

Thanks for that info sounds like you ended up with good deal, will have to push TCL to resolve situation as you said should last longer than 3 years and TV tuner faulty. I purchased through JB Hifi also but did this online so if no result through TCL will have to go and visit JB Hifi store and complain and hopefully get it fixed then will sell it off.





johny007g

logo

568 posts

Ultimate Geek

Trusted

  #2763178 19-Aug-2021 17:18
Send private message

Interestingly enough...

 

 

 

https://www.trademe.co.nz/a/marketplace/electronics-photography/tvs/led/50-60/listing/3228481762

 

 

 

Another backlight problem

 

 

 

 


johny007g
267 posts

Ultimate Geek


  #2763194 19-Aug-2021 17:47
Send private message

logo:

 

Interestingly enough...

 

 

 

https://www.trademe.co.nz/a/marketplace/electronics-photography/tvs/led/50-60/listing/3228481762

 

 

 

Another backlight problem

 

 

 

 

 

 

I actually had a look at trade me on Monday and same guy had same refurbished model with bids up to $500 and very surprised, forgot to check auction result closed on Wednesday, perhaps fell through and he's relisted. So if he's selling on behalf of TCL they must be getting money back and seems to be common problem, think listing I seen had same backlight problem. Will push TCL for repairs or CGA and see what happens, but will have to wait for lockdown to pass.





johny007g

Create new topic





News and reviews »

D-Link G415 4G Smart Router Review
Posted 27-Jun-2022 17:24


New Zealand Video Game Sales Reaches $540 Million
Posted 26-Jun-2022 14:49


Github Copilot Generally Available to All Developers
Posted 26-Jun-2022 14:37


Logitech G Introduces the New Astro A10 Headset
Posted 26-Jun-2022 14:20


Fitbit introduces Sleep Profiles
Posted 26-Jun-2022 14:11


Synology Introduces FlashStation FS3410
Posted 26-Jun-2022 14:04


Intel Arc A380 Graphics First Available in China
Posted 15-Jun-2022 17:08


JBL Introduces PartyBox Encore Essential Speaker
Posted 15-Jun-2022 17:05


New TVNZ+ streaming brand launches
Posted 13-Jun-2022 08:35


Chromecast With Google TV Review
Posted 10-Jun-2022 17:10


Xbox Gaming on Your Samsung Smart TV No Console Required
Posted 10-Jun-2022 00:01


Xbox Cloud Gaming Now Available in New Zealand
Posted 10-Jun-2022 00:01


HP Envy Inspire 7900e Review
Posted 9-Jun-2022 20:31


Philips Hue Starter Kit Review
Posted 4-Jun-2022 11:10


Sony Expands Its Wireless Speaker X-series Range
Posted 4-Jun-2022 10:25









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.