Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


AKT



308 posts

Ultimate Geek


#89900 10-Sep-2011 18:23
Send private message

I just broke the dust cover on my brand new amp :(

Any advise on how to fix the input - this thread

http://www.avsforum.com/avs-vb/showthread.php?t=919734

suggests buying a new port and swapping the shutter but I can’t find anywhere in NZ I can get the part from - any ideas?

Thanks

Andy

Create new topic
163 posts

Master Geek


  #519453 11-Sep-2011 06:28
Send private message

Older optical connections had plugs. Pergaps you can find one of those.

AKT



308 posts

Ultimate Geek


  #519555 11-Sep-2011 14:12
Send private message

lostangel: Older optical connections had plugs. Pergaps you can find one of those.



Can you expand on this - I can’t see how it would help me….

Thanks


 
 
 
 


935 posts

Ultimate Geek


  #519562 11-Sep-2011 14:26
Send private message

If its brand new then take it back as faulty

AKT



308 posts

Ultimate Geek


  #519566 11-Sep-2011 14:33
Send private message

andrewcnz: If its brand new then take it back as faulty


Well I broke it, so it isn’t really faulty - it’s a design error on Toshiba’s part I think.  I could just fix the cable in with some tape but would like to fix it properly.


2438 posts

Uber Geek

Trusted

  #519570 11-Sep-2011 14:57
Send private message

If you're up for the soldering fix in the forum you linked to, then you can get the part from digikey, just find one that matches your one

http://search.digikey.com/scripts/DkSearch/dksus.dll?Cat=525354&k=toslink&stock=1
and
http://search.digikey.com/scripts/DkSearch/dksus.dll?Cat=525357&k=toslink&stock=1

Edit: Sheet! With a $39 shipping charge you might want to buy some other bits while you're at it!

AKT



308 posts

Ultimate Geek


  #519578 11-Sep-2011 15:30
Send private message

 
Edit: Sheet! With a $39 shipping charge you might want to buy some other bits while you're at it!


I had found them already, thanks - you can see why I’m looking for a NZ supplier, the overseas ones either get you on volume (I don’t need 1000) or shipping - $39 for something that costs $2 and weighs less than an envelope!

Not looking to solder, just swap the ’shutter'

This is the sort I need:
http://media.digikey.com/photos/Toshiba%20Photos/TORX141L.jpg

Thanks

A

2438 posts

Uber Geek

Trusted

  #519590 11-Sep-2011 15:50
Send private message

Hmm you could try search trademe for faulty/cheap dvd players, and harvest the flap from them

 
 
 
 


538 posts

Ultimate Geek


  #519667 11-Sep-2011 19:44
Send private message

AKT:
andrewcnz: If its brand new then take it back as faulty


Well I broke it, so it isn’t really faulty - it’s a design error on Toshiba’s part I think.  I could just fix the cable in with some tape but would like to fix it properly.




Not really your fault, (unless you were doing something silly Wink)  If its brand new and all you did was plug/unplug a cable and it broke...  obviously it's not "fit for purpose".  I'd take it back!

3826 posts

Uber Geek


  #519670 11-Sep-2011 19:53
Send private message

In my experience, plugs don't break unless the user is doing something wrong...
Normally, it involves getting the Toslink cable jammed in the wrong way around, causing it to slip and take out the flap in the process. That has nothing to do with 'fit for purpose' unfortunately, more to do with user error.

576 posts

Ultimate Geek


  #519707 11-Sep-2011 22:08
Send private message

Can you expand on this - I can’t see how it would help me….


i think he means a blank plug. I had some on my Old optical switch. They have a little handle on them (maybe 5mm long) and fill the gap when you have no cable in the socket.


1850 posts

Uber Geek


  #519716 11-Sep-2011 22:33
Send private message

Or just buy a cheapo cable off trademe and hack off one end, shove it in and forget.

AKT



308 posts

Ultimate Geek


  #519723 11-Sep-2011 22:58
Send private message

The problem is not really one of covering the socket when not in use (as the last two posters solution would work for), but unfortunately when the shutter is missing, the cable doesn’t stay in the socket and falls out easily.  As I said, I could use some tape to keep it in, but would prefer to fix it properly with a shutter.  I am considering gluing something to the cable to make it wider so it fits.  Still kicking myself I managed to break it in the first place!

Any other ideas? or point me in the direction of an NZ supplier of the ports?

Thanks


AKT



308 posts

Ultimate Geek


  #519725 11-Sep-2011 23:04
Send private message

Dunnersfella: In my experience, plugs don't break unless the user is doing something wrong...
Normally, it involves getting the Toslink cable jammed in the wrong way around, causing it to slip and take out the flap in the process. That has nothing to do with 'fit for purpose' unfortunately, more to do with user error.


As I have said, I accept it was my error, however I can’t believe how easy it was to break (and hard to find a fix for) - this is a design floor in my book.

It is pulling the cable out (or putting it in) on an angle that causes the shutter to break - see this document from Toshiba



3826 posts

Uber Geek


  #519778 12-Sep-2011 08:54
Send private message

Another point in favour of Coax in the Toslink vs Coax debate...

3316 posts

Uber Geek

Trusted

  #519903 12-Sep-2011 12:42
Send private message

AKT:
Dunnersfella: In my experience, plugs don't break unless the user is doing something wrong...
Normally, it involves getting the Toslink cable jammed in the wrong way around, causing it to slip and take out the flap in the process. That has nothing to do with 'fit for purpose' unfortunately, more to do with user error.


As I have said, I accept it was my error, however I can’t believe how easy it was to break (and hard to find a fix for) - this is a design floor in my book.

It is pulling the cable out (or putting it in) on an angle that causes the shutter to break - see this document from Toshiba



My still be worth asking about, you may find the retailer sympathetic?

Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.