Greetings all

I have a Lenovo Thinkpad T510. This model comes without backup disks, but gives you the option of creating backup disks from a hidden partition on the drive. You can only do this once. I did it, and have a Recovery DVR that was made with Lenovo Rescue and Recovery. 

The HDD started to show signs of impending failure, so I bought a new HDD. The original hard drive was 500MB, and the replacement drive is 1TB in size. I made a backup (successfully) of the failing drive using Lenovo's backup utility, then replaced it with the new one. The new drive is recognized by the computer, but when I try to do a restore of the backup onto the new drive, it fails, saying "One or more partitions could not be restored because the partition does not exist". Lenovo has hidden partitions on their drives that contain system files, I tried creating those partitions by hand using Gparted, but the process still fails. It may be that there are some hidden cylinders on the old drive that are rendered invisible by the BIOS (they have done that in the past), but it shouldn't matter: I'm restoring a Lenovo backup to a drive in a Lenovo machine. 

The interesting part of this, is that this is the second HDD that has failed in this computer. After the first failure, I think I did what I'm doing now: put a new drive in (no messing with partitions or anything) and the system formatted it and restored the backup. The only difference this time is that the replacement drive is a different size. I have also thought of restoring the computer to factory state before attempting the restore, but the option to do so does not appear in the Rescue and Recovery utility, whether I run it from the recovery DVR, or directly from the external drive that contains the backup.

Can anyone help?