Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


1222 posts

Uber Geek
+1 received by user: 118


Topic # 161700 16-Jan-2015 14:48
Send private message

I'm struggling with autorotate on my Surface Pro 3.  It seems the only way to lock the rotation is to go into the display settings via the desktop, which is a real hassle, particularly if you want to do it quickly on the move.  The iPad has a physical switch on the side which you can set via iOS to be an autorotate lock button.  While there isn't an equivalent button on the SP3, I wondered whether it would be possible to create a tile on the Start Screen which would toggle the autorotate function on and off - that would be almost as good.  However, my google searches have been fruitless.  Does anyone know if this can be done, and if so how?  

Create new topic
116 posts

Master Geek
+1 received by user: 52


  Reply # 1216155 16-Jan-2015 15:14

CTRL + O

I happen to know as my laptops accelerometer is broken and my display stays sideways when I accidentally keep hitting it while quickly trying to lock my laptop (CTRL + L).

908 posts

Ultimate Geek
+1 received by user: 595

Trusted

  Reply # 1216158 16-Jan-2015 15:19
Send private message


Open the charm bar (swipe in from the right)








1222 posts

Uber Geek
+1 received by user: 118


  Reply # 1216176 16-Jan-2015 15:50
Send private message

Thanks.  I knew about Ctrl + O but it didn't seem to work.  I also knew about the Charms bar, but again it didn't seem to work.  The toggle was greyed out for me.

I continued my searching and discovered that when the keyboard cover is attached, the option on the charms bar is greyed out, on the assumption that you don't want it to autorotate if you're using it as a laptop.  However, if you fold it back or take it off, then the option becomes available.  After a bit of experimenting, I learned that while in laptop mode, and with the screen horizontal, the option is greyed out.  In laptop mode, but with the screen vertical, the option isn't greyed out - and then it reverts to whatever setting it was in before it was in laptop mode.  So if autorotate was on before it went into laptop mode, then it will rotate, even if the keyboard is still attached.  However if autorotate was locked before it went into laptop mode, then it stays locked.

A bit convoluted, but it looks like I've got it worked out now thanks.  I'll leave autorotate off, and when it's in tablet mode I can swipe in from the charms bar to toggle it on as needed.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.