Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


mdf



1755 posts

Uber Geek
+1 received by user: 498

Trusted
Subscriber

Topic # 228890 28-Jan-2018 11:31
Send private message

I have a Sony Vaio Pro. Was having frequent BSOD crashes and so did a full reset of Windows 10. BSOD crashes continued; I'd have a period where it would constantly crash every few minutes, but then other periods where all was well for days at a time.

 

Several BSOD crashes this morning (as I was trying to read instructions for diagnosing driver issues to stop BSOD crashes...) that culminated in "Your VAIO failed to start Windows. System recovery failed to start from the internal hard disk drive/solid-state drive." From there I could get into the BIOS (nothing obviously wrong there), but nothing else worked.

 

Some time later (as I was finding another computer to post this) I was able to boot into windows normally but immediately shut it down before breaking anything else.

 

Is this an SSD failure or potentially something else? Is there a way of better diagnosing this (I may be able to do something from Windows if it behaves)?

 

I'm happy to replace the SSD if that is the likely problem. Files etc. aren't an issue; everything important is backed up elsewhere.

 

According to the interwebz, Sony Vaio Pros use a PCIe SSD. I've never bought one of these before; is searching "PCIe SSD" sufficient or are there other things to take into account?


Create new topic
358 posts

Ultimate Geek
+1 received by user: 12

Subscriber

  Reply # 1947817 28-Jan-2018 12:01
Send private message

Can't answer your questions but I also have a Vaio Pro that had an SSD failure (at about 4 years). Advised no simple fix - has to go in for servicing. That was over a year ago. Decided to get new (non-Sony!) ultrabook instead. Will get around to fixing the Vaio "one day"

1019 posts

Uber Geek
+1 received by user: 572
Inactive user


  Reply # 1947822 28-Jan-2018 12:11
Send private message

I had similar issues with a 3 y.o. Lite-On SSD in a Dell for about 6 months. It was fine for weeks at a time and then periods of instability. I didn't realise at the time it the was the drive that was causing the problems. Fortunately I already had another drive I had installed and was gradually setting up and then one day the Lite-On completely died. I never liked Lite-On from the days of their notoriously flakey CD-ROM drives and this more recent failure served only to reinforce my bias.


 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software
13833 posts

Uber Geek
+1 received by user: 2449

Trusted
Subscriber

  Reply # 1947823 28-Jan-2018 12:14
Send private message

How old is the computer? Under warranty?

 

Two things I'd try:

 

 - Get memtest or similar, something that runs from a boot USB, and check the RAM. RAM is always the first thing I test. If it fails it could still be motherboard or similar.

 

 - Put the SSD into another computer and run some kind of testing software. I don't have anything specific to recommend. What I did when I had disk problems (that turned out to be bad RAM) was use Teracopy (free) to copy massive files around, and make sure "validate" is turned on. That does a checksum of the source and destination files. I'd format the disk first, use Macrium Reflect or similar to back up beforehand if you need to.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


2146 posts

Uber Geek
+1 received by user: 650

Subscriber

  Reply # 1947826 28-Jan-2018 12:25
Send private message

Can you boot in to safe mode OK? Anything in the event logs?

 

 

 

It could well be SSD, but i wouldn't say it's narrowed down to that. Could be plenty of things. As said above, try memtest to rule out a RAM issue too. 


3063 posts

Uber Geek
+1 received by user: 1615

Subscriber

  Reply # 1947834 28-Jan-2018 13:16
Send private message

mdf:

 

According to the interwebz, Sony Vaio Pros use a PCIe SSD. I've never bought one of these before; is searching "PCIe SSD" sufficient or are there other things to take into account?

 

 

It appears that Sony have shipped both M2 Sata and M2 PCIE drives in those laptops, and even then PCIE ones come in 2 and 4 lane variants. So, yes more things to take into account.

 

 





Information wants to be free. The Net interprets censorship as damage and routes around it.

 

Thinking about signing up to BigPipe? Get $20 credit with my referral link.


mdf



1755 posts

Uber Geek
+1 received by user: 498

Trusted
Subscriber

  Reply # 1948059 29-Jan-2018 11:02
Send private message

I ran memtest last night, and happily everything seemed to pass:

 

Result summary
Test Start Time 2018-01-28 20:22:30
Elapsed Time 2:58:48
Memory Range Tested 0x0 - 21FE00000 (8702MB)
CPU Selection Mode Parallel (All CPUs)
ECC Polling Enabled
# Tests Passed 48/48 (100%)


mdf



1755 posts

Uber Geek
+1 received by user: 498

Trusted
Subscriber

  Reply # 1948060 29-Jan-2018 11:09
Send private message

I've been looking through the event logs this morning, and there seem to be a tonne of errors and warnings (though it's just cr*pped itself again!)

 

I'm really not sure what I'm looking for.

 

Most likely (?) is a Critical level event, "Kernel-Power" - "the system has rebooted without cleanly shutting down first...". However, the next issue is "volmgr", "dump file creation failed due to error during dump creation". Not sure how to investigate this further.

 

There seem to be a lot of "DistributedCOM" - "the application-specific permission settings do not grant Local Activiation permission for the COM Server application with CLSID [digits] and APPID [more digits] to the user NT AUTHORITY\LOCAL SERVICE SID (s-1-5-19) from the address LocalHost (using LRPC) running in the application contained Unavailable SID...

 

There are also a lot of TPM errors, which I assume relate to this: https://sony-paa-pa-en-web--paa.custhelp.com/app/answers/detail/a_id/174243 . That timing would potentially be consistent with BSOD onset?

 

 

 

 

 

 


72 posts

Master Geek
+1 received by user: 16

Subscriber

  Reply # 1948072 29-Jan-2018 11:21
Send private message

I’ve had great success in recovering spindle drives with SpinRite. There are some caveats in using it with ssd.

13833 posts

Uber Geek
+1 received by user: 2449

Trusted
Subscriber

  Reply # 1948088 29-Jan-2018 12:23
Send private message

I had to use HCI memtest to find my bad RAM, memtest couldn't find it. HCI had to run for about 16 hours to find the problem. HCI runs in memory and tests 2GB RAM per instance, so you have to run multiple instances.

 

Good that memtest didn't find anything though.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


mdf



1755 posts

Uber Geek
+1 received by user: 498

Trusted
Subscriber

  Reply # 1948182 29-Jan-2018 15:09
Send private message

Hmm, further update.

 

I installed a whole lot of Sony "stuff", that included a hard drive diagnostic tool. Passed that fine. I've then also managed to boot into safe mode and run it for an hour or so under 100% CPU load using a windows 10 CPU and ram checker. No crashes.

 

I guess I'm therefore looking at some kind of driver incompatibility issue, rather than hardware failure?


mdf



1755 posts

Uber Geek
+1 received by user: 498

Trusted
Subscriber

  Reply # 1949088 31-Jan-2018 10:21
Send private message

Update: I ran the PC in safe mode for a while and everything seemed fine. Decided it was a driver issue and first port of call would be an absolutely clean install using recovery media. The recovery media let me format the SDD, but when it came time to install it decided to tell me that I didn't have a SSD/HDD installed. Oh oh.

 

I pulled the notebook apart (not entirely without incident), gave it a clean (though it was pretty dust free), pulled out and reseated the SSD. Then reinstalled windows from recovery media. It's been running fine for 24 hours so touch wood that was the problem.

 

Though not sure why a potentially loose SSD connection would be fine in safe mode?


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41


New Privacy Trust Mark certifies privacy and customer control
Posted 10-May-2018 14:16


New app FIXR connects vehicle owners to top Mechanics at best prices
Posted 10-May-2018 14:13


Nutanix Beam gives enterprises control of the cloud
Posted 10-May-2018 14:09


D-Link ANZ launches Covr Seamless Wi-Fi System
Posted 10-May-2018 14:06


Telstra, Intel and Ericsson demonstrate a 5G future for esports
Posted 10-May-2018 13:59


Spark introduces Android One with Nokia 7 plus and Nokia 6.1
Posted 8-May-2018 05:00



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.