Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




52 posts

Master Geek


#261837 17-Dec-2019 14:42
Send private message

Port mapping does not work for me since I swapped from the Spark Huawei HG659b to a new Spark Smart Modem a couple of weeks ago.

 

I am trying to access a WD Passport HDD which records my Cleverloop security cameras continuously via a security camera hub with a USB connection to the HDD, using internal port :3022. I can access it internally within the LAN but not externally.

 

Aside: I asked for help on this in another Geekzone Spark topic on the release of Smart Mesh, but have not made any progress after a couple of initial comments. I probably did myself no favours asking the question in that topic, so I have started this new one to plead for assistance! (I would happily delete my comments in the other topic to tidy that up, but Geekzone forums don't allow that of course.)

 

Although the terminology and settings are different between the 2 devices, I have carefully replicated what I had working on the HG659b faithfully onto the Spark Smart Modem.

 

The port mapping shows up fine in the Smart Modem Port Mapping List and I can access the HDD device when the device I am using to access the HDD is connected within the LAN.

 

However as soon as I try to access the HDD from outside the network via the mapping port I have set ... nothing. It just times out.

 

HG659b: Port Mapping settings
- Application = "WD Passport HDD", which maps External 5678-5678 to Internal 3022-3022 using TCP&UDP
- Internal Host = "Cleverloop-5600_Ethernet", which is the hub with my HDD device, at IP xxx.xxx.x.68
- When I am under the same LAN I can access the HDD fine using xxx.xxx.x.68:3022
- And when I am outside the network I can use my network's public IP and the designated port (yyy.yy.yy.162:5678) and it works without a hitch.

 

Spark Smart Modem: Network > NAT> Port Mapping settings
- Private IP = xxx.xxx.x.68
- Public IP = yyy.yy.yy.162
- Protocol = TCP&UDP
- Private Port = 3022-3022
- Public Port = 5678-5678
- When I am under the same network I can see the HDD as before, using xxx.xxx.x.68:3022
- However, when I use yyy.yy.yy.162:5678 outside the network it just times out

 

Re the Private IP ("xxx.xxx.x.68" above): I have locked in the Cleverloop/HDD IP by setting it up as a fixed IP under Network > LAN > LAN DHCP. This works fine and the IP never changes. The 3022 port fopr the HDD USB is also specified on the Cleverloop device and also never changes.

 

Re the Public IP ("yyy.yy.yy.162" above): I have confirmed this repeatedly using the information on the router itself (e.g. Overview > Network Status) plus checking from the outside www.whatsmyip.org and the like. For work reasons, I actually pay Spark for a Fixed IP at home so that keeps things simple anyway.

 

Re port testing: I have used www.yougetsignal.com/tools/open-ports/ and others, which all confirm the port I have supposedly opened and mapped on the Smart Modem is still closed. As an aside, I have also tested port :8081 externally because I note that the Smart Modem holds this permanently open for TR-069. That correctly shows as open when I test it using my external IP (yyy.yy.yy.162:8081), so clearly port forwarding *can* work!

 

I have wasted hours trying to fix this, including:
- often restarting the Smart Modem and/or the HDD and/or the security camera hub;
- setting and testing several different port numbers for the external port (":5678" above) such as :3022, :4567 and :60100 plus others;
- temporarily creating a Special Application with :3022 as the internal Trigger Port and :5678 (and others) as the Public Port;
- checking all router firewall and settings on the Smart Modem to ensure nothing is affecting the HDD device;
- temporarily adding the HDD device to a firewall DMZ on the router; and
- temporarily even disabling the firewall on the Smart Modem altogether.

 

Sorry to be so verbose, but I thought I would list all the relevant settings and what I have already tried to avoid wasting anyone's time.

 

Any ideas would be hugely appreciated!

 

I have just ordered a Smart Mesh device from Spark as well, so I sure hope the process goes smoother than this simple port issue with the new modem.

 

Regards,
Mark


Filter this topic showing only the reply marked as answer Create new topic
973 posts

Ultimate Geek


  #2377071 17-Dec-2019 14:44
Send private message

@hio77 may be able to chime in here but I think this issue was resolved with a firmware update? Do you know which version of firmware you're running currently?


'That VDSL Cat'
12342 posts

Uber Geek

Trusted
Spark
Subscriber

  #2377079 17-Dec-2019 14:51
Send private message

8081 isn't open past sparks network. Its an internal only connection.

As discussed in the other thread we are yet to be able to replicate your issue. It works perfectly for us.

In our remote testing we picked up the device wasn't responding how we would expect which points at an internal issue. Likely the wrong ip address.






#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 


 
 
 
 




52 posts

Master Geek


  #2377081 17-Dec-2019 14:55
Send private message

wratterus:

 

@hio77 may be able to chime in here but I think this issue was resolved with a firmware update? Do you know which version of firmware you're running currently?

 

 

Hi @wratterus

 

I heard about that, too, but haven't been able to confirm whether that is the problem with this brand new modem. The only answer I have had from Spark was a very short "port forwarding works".

 

Mine is on firmware v6.00.13 build01.

 

I did hear that some older units had a problem with retaining port-forward settings correctly but the workaround was to create 3 dummy port entries before the actual port mapping you want to work. Tried that to no avail though.

 

Thanks for your suggestion.

 

Regards,

 

Mark




52 posts

Master Geek


  #2377084 17-Dec-2019 15:01
Send private message

hio77: 8081 isn't open past sparks network. Its an internal only connection.

As discussed in the other thread we are yet to be able to replicate your issue. It works perfectly for us.

In our remote testing we picked up the device wasn't responding how we would expect which points at an internal issue. Likely the wrong ip address.

 

And hi @hio77 - sincere thanks for looking at this and sorry to double-up on your time.

 

Understood re :8081, I just thought it worth mentioning that I could see it when I tested it using my external IP. I was just pleased to see any port open! :)

 

I would infer from "likely the wrong ip address" that the set-up is wrong somewhere, so I'm all ears! What should I change?

 

I think I have listed all the relevant settings I can in this forum and also in the Geekzone DM I sent, so I am wondering what is wrong. Especially as I had it working flawless with my Huawei from Spark.

 

Thanks,

 

Mark


3906 posts

Uber Geek


  #2377123 17-Dec-2019 16:09
Send private message

Shouldn't the public IP address be set to all/0.0.0.0/none per most other port forwading methods.

 

Setting one to me indicates it would be locked to only respond to that inbound ip?. IE self. IE noone.

 

And you will always reach what you think you are port forwarding internally - that's not a method to test port forwards other than confirm the INTERNAL port number specified is right. The idea behind the Gateway/DHCP is to direct the traffic to known addresses, and anything not known ask where it is of the internet/gateway. Going internally knows its on the same lan, and crosses straight to it bypassing any port forwarding.




52 posts

Master Geek


  #2377160 17-Dec-2019 16:57
Send private message

Oblivian:

 

Shouldn't the public IP address be set to all/0.0.0.0/none per most other port forwading methods.

 

Setting one to me indicates it would be locked to only respond to that inbound ip?. IE self. IE noone.

 

And you will always reach what you think you are port forwarding internally - that's not a method to test port forwards other than confirm the INTERNAL port number specified is right. The idea behind the Gateway/DHCP is to direct the traffic to known addresses, and anything not known ask where it is of the internet/gateway. Going internally knows its on the same lan, and crosses straight to it bypassing any port forwarding.

 

 

Hi @Oblivian

 

Thanks very much for the post.

 

I realise the internal test is not testing port forwarding per se - all I meant by including that is to confirm that the device is working and available on the LAN. However ...

 

While I preferred to forward only a specific object and that had always worked well on the Huawei, I hadn't thought of your suggestion of forwarding all IPs. So I set a new port mapping rule to 0.0.0.0 for external (All/None are not options) ... and it worked!

 

I understand that forwarding all IPs in this manner should be safe so this looks like a good solution.

 

Sincerest thanks!

 

Regards,
Mark


3906 posts

Uber Geek


  #2377168 17-Dec-2019 17:12
Send private message

unless the device on the outside world you're trying to attach to your network with has a static IP that you can specify there you have to set all. otherwise use a VPN client and you'll be able to use the internal address

although more complex to set up it is the more secure and preferred method than opening up your computer to the world

 
 
 
 




52 posts

Master Geek


  #2377169 17-Dec-2019 17:14
Send private message

Oblivian: unless the device on the outside world you're trying to attach to your network with has a static IP that you can specify there you have to set all. otherwise use a VPN client and you'll be able to use the internal address

although more complex to set up it is the more secure and preferred method than opening up your computer to the world

 

Understood -thanks again!


'That VDSL Cat'
12342 posts

Uber Geek

Trusted
Spark
Subscriber

  #2377174 17-Dec-2019 17:40
Send private message

Oblivian: unless the device on the outside world you're trying to attach to your network with has a static IP that you can specify there you have to set all. otherwise use a VPN client and you'll be able to use the internal address

although more complex to set up it is the more secure and preferred method than opening up your computer to the world

 

Weird one, it doesnt show like that when we look on our side.

 

 

 

Great catch though, Thank you @Oblivian.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 


Filter this topic showing only the reply marked as answer Create new topic





Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus completes the build and commissioning of two new core Ethernet switches
Posted 8-Jul-2020 09:48


National Institute for Health Innovation develops treatment app for gambling
Posted 6-Jul-2020 16:25


Nokia 2.3 to be available in New Zealand
Posted 6-Jul-2020 12:30


Menulog change colours as parent company merges with Dutch food delivery service
Posted 2-Jul-2020 07:53


Techweek2020 goes digital to make it easier for Kiwis to connect and learn
Posted 2-Jul-2020 07:48


Catalyst Cloud launches new Solutions Hub to support their kiwi Partners and Customers
Posted 2-Jul-2020 07:44


Microsoft to help New Zealand job seekers acquire new digital skills needed for the COVID-19 economy
Posted 2-Jul-2020 07:41


Hewlett Packard Enterprise introduces new HPE GreenLake cloud services
Posted 24-Jun-2020 08:07


New cloud data protection services from Hewlett Packard Enterprise
Posted 24-Jun-2020 07:58


Hewlett Packard Enterprise unveils HPE Ezmeral, new software portfolio and brand
Posted 24-Jun-2020 07:10


Apple reveals new developer technologies to foster the next generation of apps
Posted 23-Jun-2020 15:30


Poly introduces solutions for Microsoft Teams Rooms
Posted 23-Jun-2020 15:14


Lenovo launches new ThinkPad P Series mobile workstations
Posted 23-Jun-2020 09:17


Lenovo brings Linux certification to ThinkPad and ThinkStation Workstation portfolio
Posted 23-Jun-2020 08:56


Apple introduces new features for iPhone iOS14 and iPadOS 14
Posted 23-Jun-2020 08:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.