Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




24 posts

Geek


# 42814 11-Oct-2009 21:39
Send private message

I've recently installed a SPA2102 at home for VoIP using 2talk. 

I'm on telstra cable, so have quite a fast connection, and a static IP. I've got  my normal phone connected to SPA2102, connected to my Linksys router via ethernet. 

I set it all up with the instructions at http://blog.2talk.co.nz/spa2102.html - I managed to follow the instructions, apart from updating the firmware (I downloaded the firmware installer, but it wouldn't upload to the device!).

I've  got no probs calling out, but I have had a few issues with people trying to call in and getting no tone whatsoever. I also just had a call from overseas, and the phone didn't ring, I just got a voicemail. Generally, calling my home phone from my cellphone works fine, but I know that people have tried calling from their home phone and gotten no tone. I've then tried calling from my cellphone, and also had no dial tone. When I then call my voicemail from home phone and hang up, I call my home from my cell and the phone rings.

The SPA2102 uses dhcp, and as such I haven't set up port forwarding. Is this something I should be doing?If so, what ports should I be forwarding?

Any ideas on what would make my phone more reliable would be really handy :)

Create new topic
391 posts

Ultimate Geek

Trusted

  # 263408 12-Oct-2009 09:19
Send private message

It does sound like a possible NAT issue. If you can try a different router that would confirm it.




37 posts

Geek


  # 263495 12-Oct-2009 14:26
Send private message

definitely try setting up port 5060/udp (SIP) inbound into the ATA.  It sounds like your router may not be passing established connections through so you may need to open up the port.

 
 
 
 




24 posts

Geek


  # 263498 12-Oct-2009 14:37
Send private message

Ok, I'll give that a go and let you know how it turns out. I gave my home phone a test today -ringing from a landline, I got an extremely short ringing tone, and then no tone. Will try the port forwarding.



24 posts

Geek


  # 263790 13-Oct-2009 23:07
Send private message

I've setup my Linksys router to forward port 5060 to 192.168.1.11

I'm trying to figure out how I setup the spa2102 so that it doesn't use DHCP for getting assigned its IP address (which I want to be 192.168.1.11). The SPA2102 has WAN and LAN setup tabs, so I've tried to change the WAN settings, so that it has a static IP rather than using DHCP.

I've set the static IP to 192.168.1.11
The netmask to 255.255.255.0
The Gateway (my router address) which is 192.168.1.1

When I switch from DHCP to Static, I can no longer get a line out - so obviously it's not working.

Can anyone give me some tips on how to get the port forwarding working?



24 posts

Geek


  # 263956 14-Oct-2009 21:21
Send private message

Ok , so I've noticed that When I assign the static IP (192.168.1.11) on the SPA2102 and enable the web server on it, then I can connect to the web interface via the network rather than connecting directly with it.

The problem is that calls in and out no longer work!

My setup currently looks like this:

Internet
---->Linksys router (local IP: 192.168.1.1) port fwd 5060 to 192.168.1.11
-----------> Linksys SPA2102 (192.168.1.11)
-------------------> Normal phone

I'm not sure why the phone calls aren't working..... I'm sure there's heaps of people here that are more clued up than what I am - any ideas?



24 posts

Geek


  # 263963 14-Oct-2009 22:01
Send private message

Ok, i fixed the issue - I entered in the dns settings from my router into the SPA2102 settings, and calls are now working with a local static IP and port forwarding. Will just have to do some testing now to see if it's made a difference to the reliability of it all :)

283 posts

Ultimate Geek


  # 263964 14-Oct-2009 22:02
Send private message

I had a similar issue with my Linksys PAP2T, it thought it was registered but sometimes wouldn't recieve calls, rebooting it fixed it although it would reoccur again.  It seems the router was closing the incoming port that it was using to recieve incoming notifications. 

I had to change the UDP timeout on my router from the default 120 seconds to 240 seconds.  Also ensure sure you have NAT keepalive enabled on the voip adapter.  My register expires on the adapter is set to 600 seconds.

I think NAT keepalive was what fixed it for me.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32


Vodafone 5G service live in four cities
Posted 10-Dec-2019 08:30


Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01


NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00


New Zealand Rugby Selects AWS-Powered Analytics for Deeper Game Insights
Posted 5-Dec-2019 11:33


IMAGR and Farro bring checkout-less supermarket shopping to New Zealand
Posted 5-Dec-2019 09:07


Wellington Airport becomes first 5G connected airport in the country
Posted 3-Dec-2019 08:42


MetService secures Al Jazeera as a new weather client
Posted 28-Nov-2019 09:40


NZ a top 10 connected nation with stage one of ultra-fast broadband roll-out completed
Posted 24-Nov-2019 14:15


Microsoft Translator understands te reo Māori
Posted 22-Nov-2019 08:46


Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.