Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

Topic # 162194 1-Feb-2015 19:33
Send private message

I'm having trouble getting Windows 10 to share files without asking for a username and password. My main client is Kodi/XBMC running on an R.Pi, but I have a Win 8.1 laptop to check things with.

I have a directory of videos, I've added permissions so "everyone" and "anonymous" have read permissions. I've set up "advanced sharing" so that public sharing is on, and I've changed the settings as recommended by various websites. I've exited a home group that was created automatically, it may have put me into another one. Windows firewall is off, only antivirus is windows defender. I've spent about an hour so far, it's fairly frustrating. I remember it was similar getting W7 to share files, I changed just about every network and sharing setting I think.

I can post screen shots later - I'm in W7 right now so I can use Kodi on the TV.

No matter what I do when I browse to the share from another PC it always pops up a box asking for username and password. Can anyone suggest anything?




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
973 posts

Ultimate Geek
+1 received by user: 419

Trusted
Subscriber

  Reply # 1227278 1-Feb-2015 20:14
Send private message

If they are all W7 or later machines set up a Homegroup. You can then share the required folders with Homeusers. Much safer than what you are doing.







14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1227280 1-Feb-2015 20:17
Send private message

I mostly share with Kodi/XBMC running on a Raspberry Pi. I share a few folders with my wife too.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1227309 1-Feb-2015 20:50
Send private message

I was about to say I have a workaround - I created a local account and that worked ok via the laptop. But then I went and tried the R.Pi and it worked as well. No idea why.

Damn computers.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


JWR

739 posts

Ultimate Geek
+1 received by user: 237


  Reply # 1227342 1-Feb-2015 21:46


You could use a free DLNA server e.g. Serviio, Universal Media Server (UMS) etc.

I think Kodi works with that and it will also work with a smart TVs, Tablets etc.



14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1227392 2-Feb-2015 07:27
Send private message

I have PS3 Media Server on W7 but that's really just for the PS3. Kodi just needs file shares. Worth a shot if I get desperate.

However it started working last night, I have no idea why because I changed quite a few settings - firewall, advanced sharing, permissions, encryption settings, etc.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1227959 2-Feb-2015 18:08
Send private message

Pretty sure the answer is: the Windows 10 firewall prevents SMB access. Turning it off lets Kodi work. I haven't found a way to let SMB through the windows 10 firewall yet... I think it's a work in progress.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


1508 posts

Uber Geek
+1 received by user: 213


  Reply # 1228979 2-Feb-2015 20:30
Send private message

If you go to the network and sharing center (right click on network icon in system tray) then open advanced sharing options in there from the left hand panel, is file and printer sharing enabled? Also further down is streaming options. Look in there and there should be streaming options and also a list of devices that have tried to read shared media. You may have the Pi in there as blocked and you just need to enable it. This has been the case with my Xbox and Samsung Blu-Ray player. Once enabled in there, all was well. 




Try Vultr using this link and get us both some credit:

 

http://www.vultr.com/?ref=7033587-3B




14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1228987 2-Feb-2015 20:43
Send private message

Thanks Paul. I think it was first those settings you mentioned, which I changed yesterday, then windows firewall. I can't work out how to allow a port through the firewall, whatever SMB is on.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


2066 posts

Uber Geek
+1 received by user: 343

Lifetime subscriber

  Reply # 1229021 2-Feb-2015 21:29
Send private message

timmmay: Pretty sure the answer is: the Windows 10 firewall prevents SMB access. Turning it off lets Kodi work. I haven't found a way to let SMB through the windows 10 firewall yet... I think it's a work in progress.


File and Printer Sharing (SMB-In) TCP on 445 rule should be enabled to allow if file and printer sharing is turned on. I just tested it couldn't find any issue.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


2066 posts

Uber Geek
+1 received by user: 343

Lifetime subscriber

  Reply # 1229025 2-Feb-2015 21:31
Send private message

paulmilbank: If you go to the network and sharing center (right click on network icon in system tray) then open advanced sharing options in there from the left hand panel, is file and printer sharing enabled? Also further down is streaming options. Look in there and there should be streaming options and also a list of devices that have tried to read shared media. You may have the Pi in there as blocked and you just need to enable it. This has been the case with my Xbox and Samsung Blu-Ray player. Once enabled in there, all was well. 


I don't believe those streaming options relate to SMB, more likely to Windows Media Player Sharing Service.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1230091 3-Feb-2015 05:39
Send private message

Spyware:
timmmay: Pretty sure the answer is: the Windows 10 firewall prevents SMB access. Turning it off lets Kodi work. I haven't found a way to let SMB through the windows 10 firewall yet... I think it's a work in progress.


File and Printer Sharing (SMB-In) TCP on 445 rule should be enabled to allow if file and printer sharing is turned on. I just tested it couldn't find any issue.


Yeah they are on. I read something about Netbios providing name resolution for SMB?




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 1297921 4-May-2015 20:52
Send private message

Did you ever figure this out? I've just been trying to set up a real simple folder share to allow the WDTV and my android phone to see it from Windows 10. Even with passwords off it won't let me open the shared folder from those devices. The best answer I could find was this. Seems to be related to if you use a microsoft account as opposed to a Local account in Windows 8 onwards. I'm no IT pro, but this seems a bizzare and annoying limitation to me.



14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1298035 5-May-2015 07:49
Send private message

CutCutCut: Did you ever figure this out? I've just been trying to set up a real simple folder share to allow the WDTV and my android phone to see it from Windows 10. Even with passwords off it won't let me open the shared folder from those devices. The best answer I could find was this. Seems to be related to if you use a microsoft account as opposed to a Local account in Windows 8 onwards. I'm no IT pro, but this seems a bizzare and annoying limitation to me.


I marked an answer above - have you tried turning the firewall off. Also I know there's an advanced networking section somewhere (I can't recall where) where you can tweak things like network encryption, who can connect, etc. I could probably find it if I was at home - if you PM me after 5pm to remind me I can try to find it for you.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 1298038 5-May-2015 07:59
Send private message

Thanks, yes I did try turning off the firewall, didn't help. I'll have another look tonight and see if I can find anything. The only solution I found online was to create a new local account, and create shares that way. But I'd rather not have to gong create extra accounts etc.



14222 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1298045 5-May-2015 08:12
Send private message

I do have a local account, but I don't remember if I created the shares using it. Have you checked file and share permissions?




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.