Did a vanilla installation of Windows 8.1 upgraded to Windows 10 for a lawyer/friend. He needs to be able to run XP apps (cost to migrate to later version  > $20K) so I thought the best way would be to fire up a Hyper-V instance and put XP SP3 on it.

 

That worked fine and I can access the Windows 10 shares as well as the network shares from the XP instance by creating a virtual switch and then virtual network adapter.

 

On the Windows 10 instance, used fixed IP for the machine because we don't want to use DHCP.  With that in place able to access the Internet fine.

 

However when I tried to access shares on the network kept getting unknown errors and when I did the diagnostic and repair, that would fail. The message was some protocols required for file sharing and delving deeper got this message

 

Windows Sockets Registry Entries Required For Network Connectivity Are Missing

 

The strange thing was the XP VM could access the network sharess but the host could not.

 

Tried all the fixes I found via Google and nothing worked. Then looking at the network adapters noticed there was the physical adapter and a virtual switch (not connected), created for Hyper-V I guess. Manually went in and configured the virtual switch to have its own IP address in the same subnet and ignored Windows warnings about duplicate adapters on the same subnet and once I did that, the host could see the shares.

 

Happy that it worked but have no idea why. 

 

Thoughts?