We have been installing Intel NUC boxes for quite a number of years. We used to love them - they were rock steady, unobtrusive and stable.  Our accountant hated them - they were rock steady, unobtrusive and stable - and that's bad for the bottom line.

 

 

 

In the last 12 months our accountant has begun smiling more often and my 'bang head here' sheet has worn out. Windows 10 on Intel NUCS has been a whole lot more problematic. The last four installed all caused nightmares.  They were all Windows 10 issues. New , clean installs.

 

The latest is Windows 10 freezing for 30 seconds or longer. It wouldn't respond at all. There was a repeated error showing for stornv  and also the error message: Reset to device \Device\RaidPort0, was issued in the error logs in Windows 10

 

Our NUCS don't have RAID, especially for desktops - so the error is frustrating and misleading. After much research I found the issue is that SSD drives and AHCI have issues under Windows 10. There is aggressive power management going on, even in the balanced and high performance power profiles, dropping out the SATA / Disk connections.

 

 

 

Thought I would share our fix here: I'm sure I'm not the only one who will run into this.

 

Hardware: Intel NUC / Adata SSD Drive.

 

 

 

To stop the aggressive power management you have to:

 

Go to Advanced Power  Settings

 

But to change AHCI settings in power management may not be possible as Microsoft seem to have removed them. It takes a registry hack to re-enable them:

 

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ControlPower\PowerSettings\012ee47-9041-4b5d-9b77-535fba8b1442\b2d69d7-a2a1-449c-9680-f91c70521c60
  • Change Attributes to 2 to see one of the AHCI Settings
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ControlPower\PowerSettings\012ee47-9041-4b5d-9b77-535fba8b1442\dab60367-53fe-4fbc-825e-521d069d2456.
  • Change Attributes to 2 to see other of the AHCI Settings

 

 

 

 

     

  1. Click Change plan settings > Change advanced power settings to open the Power Options window.
  2. Double-click Hard disk to expand its options.
  3. Double-click AHCI Link Power Management – HIPM/DIPM 
  4. Change both On battery and Plugged in options to Active.
  5. Double click AHCI Link Power Management – Adaptive
  6. Change On battery and Plugged in settings to 0.
  7. Double-click Turn off hard disk after and adjust its On battery and Plugged in options to Never ( or set it to zero minutes - which is the same thing)

 

 

 

Reboot - All should work well.

 

As always check all drivers are up to date.

 

 

 

This fixed our issue but it took a bit of Google searching and a few different sites to get the complete fix sorted out. None of the Microsoft forums helped - all ended up giving up on the process.