Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




6 posts

Wannabe Geek


Topic # 7305 4-Apr-2006 22:15
Send private message

Hi,

Windows XP Pro SP2

I have recently added a new hard drive to my computer. Ever since then, when I try to use my USB mass storage or plug my camera in to my PC. They don't show up in "My Computer". They did before I added the hard drive.

My PC recognises that they are attached ie:they are in Device Manager, show up in Hardware and in Admin Tools under Disc Drives.

The only way that I have been able to access the files on these drives is by sharing them on my network. Then going in to My Network Places and opening the network folder.

Where else should I be looking to change something to make my PC do what it was doing before ie: Plug something in and it shows up in "My Computer" under Removable Media as a drive.

The only place I haven't been to change anything since I added the new hard drive is the BIOS. Should I be changing something there? (I would give it a go now but I have been and am currently in the middle of a sizeable download and do not want to lose my place)

Any help or tips would be greatly appreciated.

I'm not completely ignorant around a computer and have generally been able to find the help before asking, but this one is getting the better of me.

Thanks,

Create new topic
BDFL - Memuneh
59163 posts

Uber Geek
+1 received by user: 10401

Administrator
Trusted
Geekzone
Subscriber

Reply # 32242 4-Apr-2006 22:24
Send private message

It could be that this new drive is conflicting with the removable media. You can try clicking Start, and then right-click on your computer's name. Then select Manage.

Find Disk Management and check that you can see the removable media there. You can reassign a drive letter to the new hard drive, to resolve the conflict. Then move the removable media to another letter, and move the new drive back.







6 posts

Wannabe Geek


Reply # 32393 5-Apr-2006 23:52
Send private message

Hi, thanks

But, I have tried going in to Disk Management and changing drive letters. Doesn't seem to make any difference. Device manager says that there are no conflicts and the are no "Warning" signs.?

At the moment, I can go in to Disk Management and right click on my USB Mass Storage device and click Open. And it will open fine. But I can't see it in "My Computer" under Removable Media with my CD-ROM and my 3.5" Floppy. Before I added my new hard drive I would push it in and it would pop up under Removable Storage in "My Computer".

Should I be changing anything in the BIOS settings?

 
 
 
 


BDFL - Memuneh
59163 posts

Uber Geek
+1 received by user: 10401

Administrator
Trusted
Geekzone
Subscriber

Reply # 32394 5-Apr-2006 23:54
Send private message

No, I don't think it's anything in the BIOS. Interesting you say it will open, just not show up in the list. I wonder if there's an option to hide removable media.





652 posts

Ultimate Geek
+1 received by user: 27

Trusted
Subscriber

Reply # 32396 6-Apr-2006 00:15
Send private message

If after you have connected the USB drive to your PC and highlighted the drive from within Disk Management, does the drive THEN show up in Windows Explorer? (i have seen this happen - even if the drive has a correctly assigned drive letter, simply selecting it from within DM seemed to make it show in Windows Explorer, crazy)

From within Windows Explorer, does it show if you expand Control Panel > Portable Media Devices ??



6 posts

Wannabe Geek


Reply # 32397 6-Apr-2006 00:24
Send private message

No it doesn't show up in Windows Explore after I highlight it within DM.

When I go to Control Panel/Portable Media Devices. Nothing happens when I double click Portable Media Devices.

One other thing that may or may not help.

After I added the new hard drive, I also added a USB Hub(4 port).


Thanks,

652 posts

Ultimate Geek
+1 received by user: 27

Trusted
Subscriber

Reply # 32398 6-Apr-2006 00:30
Send private message

are you connecting the USB drive directly to the PC or through the hub?

652 posts

Ultimate Geek
+1 received by user: 27

Trusted
Subscriber

Reply # 32399 6-Apr-2006 00:53
Send private message

just had a thought, from within the BIOS of your PC there may be a setting somewhere to turn on/off USB mass storage... so it may pay to take a look in there if you haven't already and just check that this is on (i would imagine it is otherwise you wouldn't be able to see the drive from even within the disk management console - but hey, who knows)



6 posts

Wannabe Geek


Reply # 32642 9-Apr-2006 18:50
Send private message

Windows XP Professional 5.1 Service Pack 2 (Build 2600)
Processor info: Intel(R) Pentium(R) 4 CPU 3.00GHz x 2 (2992MHz)
Memory Available to Windows: 2,096,620 KB

I have now pulled the new hard drive out to see whether or not it makes a difference.

And, it doesn't. When I plug my mass storage or my sony camera in, I still cannot see them in "My Computer" under removable media. The only way I can get info off them is by sharing them on the network in Disk Management, then going to My Network Places.

I just don't understand what I could have done to make this so.

After going in to the BIOS settings I saw that c: is the master and the new drive I connected was the slave. The other IDE port on my mother board is used for my CD-ROM(D:). But, the CD-ROM was the slave drive and there was no master for Port 1 of the IDE ports. (Whether any of this actually helps or not)

What info do I need to supply to someone for them to be able to help me, please. (Other than taking my PC to a techo)

1 post

Wannabe Geek


Reply # 33597 21-Apr-2006 20:46
Send private message

I'm having the exact same problem, accept mine happened after I installed SP2. Beforehand, I had no service pack. However, I did quite a bit of 'cleaning up' in between installing SP2 and trying to use a flash drive, so the problem could be something else.

The problem occus to all USB removable storage devices... USB Pens, Sony PSP, Cameras... the lot!

I've been searching for ages and just found forum posts like this one that have stopped without solutions, and I'm guessing it's some registry issue.

Please someone help us!

16 posts

Geek


Reply # 33599 21-Apr-2006 21:34
Send private message

Its windows fault (it sucks)

Download a good linux distro and install that you want have any problems!!!!!!!!

BDFL - Memuneh
59163 posts

Uber Geek
+1 received by user: 10401

Administrator
Trusted
Geekzone
Subscriber

Reply # 33600 21-Apr-2006 22:07
Send private message

I don't think the solution is installing another OS. Before turning this thread (and others) into a "Windows x Linux" war which effectively doesn't help anyone, it would be good to have suggestions that could actually help solve the problem at hand.

The OP have this problem since installing a new hardware. The second poster had a problem after a "clean up". I bet this is a problem with drivers, and even Linux has problems with drivers.

First of all, check if the new hardware you are installing comes with its own drivers. Use those if possible. For the second problem, cgeck that you didn't remove any driver - for example did you manage to use the USB memory key between the "clean up" and the SP2 installation?





1 post

Wannabe Geek


Reply # 33683 23-Apr-2006 08:47
Send private message

I had the same problem, try this:

  Go to Control Panel>AdminTools>Computer Manage>Disk Manage>See if your
drive shows up there.
   If yes then rt click and assign a drive letter to initialize it,  I just gave the drive a different letter.

Hope that works. 



6 posts

Wannabe Geek


Reply # 33693 23-Apr-2006 12:10
Send private message

It just doesn't seem like (or rather it isn't) automatically assigning a drive letter when I plug a USB device in



6 posts

Wannabe Geek


Reply # 33695 23-Apr-2006 12:28
Send private message

Bugger. I just realised after my last reply that a big long reply that I had done this morning hadn't been posted.

Although I think that last little statement about the PC not assigning a drive letter automatically pretty much sums it up.


At the moment. I plug a USB device in. I have to go to Control Panel/Admin Tools/Computer Management/Disk Management. Right click on the device. Assign a letter to it. Right click again and go to Properties/Sharing and share the drive on the network(even though I only have one PC). Then go to My Network Places and it is USUALLY there.


Just some relevant info below, maybe.

C: Partition Basic NTFS Healthy(System) -My main drive
J: Simple Dynamic NTFS Healthy -The new drive(Dynamic looked and sounded better at the time of format)???
F: Partition Basic FAT32 Healthy -USB Mass Storage
G: Partition Basic FAT Healthy -Sony camera

27 posts

Geek


Reply # 34860 4-May-2006 17:54
Send private message

its not an extremely bad thing that you can't see your drive in my computer if you can open it by other means. If it really worries you though you could reformat the computer if you can't work out anything else

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23


New Fujifilm macro lens lands in New Zealand
Posted 5-Dec-2017 20:16


Cyber security not being taken seriously enough
Posted 5-Dec-2017 20:13


Sony commences Android 8.0 Oreo rollout in New Zealand
Posted 5-Dec-2017 20:08


Revera partners with Nyriad to deliver blockchain pilot to NZ Government
Posted 5-Dec-2017 20:01



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.