Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




72 posts

Master Geek
+1 received by user: 2


Topic # 119350 29-May-2013 09:46
Send private message

Hi

I am configuring a headless remote server with a ZTE MF363 modem connected to the Telecom network.
The server is running Ubuntu 12.04.
I have done this before as described in the post: Configuring a MF626 T-Stick

This time, everything seems to work except that I can't ping anything.
I tried pinging google after running sudo wvdial from the CLI
$>ping 8.8.8.8
but didn't get a response.
Last time I fixed this by adding to /etc/ppp/options the following line:

replacedefaultroute

When that was done, everything worked but not this time. I don't have direct access to the 1st system, so I can't do a side-by-side comparison.

I think this is some problem with the ppp0 network configuration or file permissions rather than the modem config.

the wvdial file contains:
[code]
[Dialer Defaults]
Modem = /dev/ttyUSB2
Modem Type = Analog Modem
ISDN = 0
Baud = 460800
Dial Attempts = 3
Phone = *99#
Password = pass
Username = user
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = ATS7=60 S30=0 S0=0
Init4 = AT+CGDCONT=1,"IP","wap.telecom.co.nz"
Stupid Mode = 1
[/code]
This worked OK with the MF626 modem. wvdial doesn't throw up any error messages with the MF636

$>ifconfig
gives the following response (I have not included the eth0 and lo responses)

ppp0 Link encap:Point-to-Point Protocol
inet addr:10.219.126.218 P-t-P:10.64.64.64 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:147 errors:9 dropped:0 overruns:0 frame:0
TX packets:148 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:12197 (12.1 KB) TX bytes:10579 (10.5 KB)

The pppO appears to be working and packets are being Txd, Rxd OK

The output from syslog:
[code]
May 28 21:34:32 alpha pppd[4542]: pppd 2.4.5 started by root, uid 0
May 28 21:34:32 alpha pppd[4542]: Using interface ppp0
May 28 21:34:32 alpha pppd[4542]: Connect: ppp0 /dev/ttyUSB2
May 28 21:34:32 alpha pppd[4542]: CHAP authentication succeeded
May 28 21:34:32 alpha pppd[4542]: CHAP authentication succeeded
May 28 21:34:32 alpha ntpd[4500]: ntpd exiting on signal 15
May 28 21:34:34 alpha pppd[4542]: Could not determine remote IP address: defaulting to 10.64.64.64
May 28 21:34:34 alpha pppd[4542]: replacing old default route to eth0 [192.168.1.2]
May 28 21:34:34 alpha pppd[4542]: local IP address 10.218.181.52
May 28 21:34:34 alpha pppd[4542]: remote IP address 10.64.64.64
May 28 21:34:34 alpha pppd[4542]: primary DNS address 202.27.158.40
May 28 21:34:34 alpha pppd[4542]: secondary DNS address 202.27.156.72
May 28 21:35:12 alpha ntpdate[4607]: adjust time server 124.47.130.12 offset -0.290184 sec
May 28 21:35:12 alpha ntpd[4666]: ntpd 4.2.6p3@1.2290-o Tue Jun 5 20:12:11 UTC 2012 (1)
May 28 21:35:12 alpha ntpd[4667]: proto: precision = 0.980 usec
May 28 21:35:12 alpha ntpd[4667]: ntp_io: estimated max descriptors: 1024, initial socket boundary: 16
May 28 21:35:12 alpha ntpd[4667]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
May 28 21:35:12 alpha ntpd[4667]: Listen and drop on 1 v6wildcard :: UDP 123
May 28 21:35:12 alpha ntpd[4667]: Listen normally on 2 lo 127.0.0.1 UDP 123
May 28 21:35:12 alpha ntpd[4667]: Listen normally on 3 eth0 192.168.1.96 UDP 123
May 28 21:35:12 alpha ntpd[4667]: Listen normally on 4 ppp0 10.218.181.52 UDP 123
May 28 21:35:12 alpha ntpd[4667]: Listen normally on 5 lo ::1 UDP 123
May 28 21:35:12 alpha ntpd[4667]: peers refreshed
May 28 21:35:12 alpha ntpd[4667]: Listening on routing socket on fd #22 for interface updates
[/code]
This appears to show that ppp0 connects normally and that the ntp client is then able to update the time. If so, then the server can see the internet.

The file /etc/networks/interfaces contains:


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.96
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.2
# dns-* options are implemented by the resolvconf package, if installed
# Telecom DNS servers
dns-nameservers 202.27.158.40
dns-search home.org

# Telecom T-Stick network
auto ppp0
iface ppp0 inet wvdial


So this should auto start ppp0 after reboot and if it drops out.


Any pointers on where to look next would be appreciated.

Create new topic
73 posts

Master Geek
+1 received by user: 4


  Reply # 827564 29-May-2013 10:12
Send private message

It is not just Telcom blocking ping?
Try some other test, say a DNS lookup



72 posts

Master Geek
+1 received by user: 2


  Reply # 827613 29-May-2013 11:29
Send private message

Hi

I don't know if Telecom blocks pings.

I have found a bug report that is consistent with my symptoms.
[url=https://bugs.launchpad.net/ubuntu/+source/ppp/+bug/608372]
I will try the fix tonight.

 
 
 
 




72 posts

Master Geek
+1 received by user: 2


  Reply # 828147 30-May-2013 09:27
Send private message

Hi
The bug report identified the solution.

Adding the options

defaultroute
  replacedefaultroute


to the etc/ppp/options file fixed the problem.
These options change the default route so that ppp0 is the gateway to the internet while the ppp0 interface is open.
When ppp0 closes, the default route reverts to the eth0 interface.


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone TV — television in the cloud
Posted 17-Oct-2017 19:29


Nokia 8 review: Classy midrange pure Android phone
Posted 16-Oct-2017 07:27


Why carriers might want to embrace Commerce Commission study, MVNOs
Posted 13-Oct-2017 09:42


Fitbit launches Ionic, its health and fitness smartwatch
Posted 12-Oct-2017 15:52


Xero launches machine learning automation to improve coding accuracy for small businesses
Posted 12-Oct-2017 15:45


Bank of New Zealand uses Intel AI to detect financial crime
Posted 12-Oct-2017 15:39


Sony launches Xperia XZ1, a smartphone with real-time 3D capture
Posted 11-Oct-2017 10:26


Notes on Nokia’s phone comeback
Posted 10-Oct-2017 10:06


Air New Zealand begins Inflight Wi-Fi rollout
Posted 9-Oct-2017 20:16


The latest mobile phones in perspective
Posted 9-Oct-2017 18:34


Review: Acronis True Image 2018 — serious backup
Posted 8-Oct-2017 11:22


Lenovo launches ThinkPad Anniversary Edition 25
Posted 7-Oct-2017 23:16


Less fone, more tech as Vodafone gets brand make-over
Posted 6-Oct-2017 08:16


API Talent Achieves AWS MSP Partner Status
Posted 5-Oct-2017 21:20


Stellar Consulting Group now a Domo Partner
Posted 5-Oct-2017 21:03



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.