Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




65 posts

Master Geek
+1 received by user: 1


Topic # 57276 8-Feb-2010 12:03
Send private message

Hi, I'm just beginning to learn about Linux networking, so please bear with me. I have a home WiFi network that has been working fine for ages, which currently supports two Windows-based laptops and a WM5 smartphone. They all connect to the WiFi router (Linksys WRT54G) which in turn connects to the ADSL modem (Huawei MT882). The router is configured with a WEP key, the SSID is not being broadcast, and all MAC addresses must be whitelisted. I try to follow good wireless network security practice. I also have NAT running between the router and the modem.

Everything is working fine for the Windows clients, and now I am trying to add my Linux box to the mix. I am setting up an older HP Pavilion 510a desktop with Ubuntu v8.04LTS, using a Realtek RTL8185 WLAN card. The machine has an onboard RTL8139 LAN adaptor also, which works fine when I plug it in directly to an ethernet port on the wireless router. The WLAN, however, does not seem to be getting a DHCP packet, and keeps on autoconfiguring with a 169.254.x.x address. When I try giving it a static IP address it doesn't connect either.

As you can see from the screenshots below, the WLAN is working fine. I have it installed using the ndiswrapper and Windows drivers. I've been through the Comprehensive ndiswrapper troubleshooting guide but that did not resolve my problem.





I configured the network myself, and it works perfectly for my Windows machines. It is just my lack of experience with Linux which is preventing me from getting the wireless to work under Linux. I can get a HDCP packet in Linux when I am connected to the LAN using the RTL8139 adaptor, but not on the WLAN using the RTL8185 adaptor. Any advice would be appreciated.

CROSSPOSTED on the Ubuntu Forums for a wider audience.

Create new topic
2820 posts

Uber Geek
+1 received by user: 246


  Reply # 297046 8-Feb-2010 13:48
Send private message

I've found that when you have problems like this it is best to disable all the security on the wireless access point and see if you can connect.
Once that is working then start enabling the security features one at a time and testing that you can still connect.
Start by turning on WEP then enable the MAC filtering and lastly turn off SSID broadcast (SSID broadcast is not really a security feature though so I wouldn't even bother with that - If you are really worried about security then use WPA or even better WPA2 with a strong key.)






65 posts

Master Geek
+1 received by user: 1


  Reply # 297080 8-Feb-2010 15:36
Send private message

Thanks for the suggestion CYaBro. I had already considered doing as you suggested, and disabling all of my security settings, except that they are working fine on the Windows machines, and I don't want to have to reconfigure those which are already working. As the saying goes... "if it works, don't fix it".

I'd prefer a solution for the Linux machine that isn't working, rather than something that will interfere with the working Windows machines. My wife won't be too happy either if I have to temporarily disconnect her laptop from the network just to get Linux working wirelessly. ;)

Unfortunately my smartphone isn't quite smart enough to support WPA, that is why I'm only using WEP on my home network. As for the SSID broadcasting, it's a bit like the old proverbial Win98 login password. It doesn't protect from any determined attackers, but from those who don't know any better, it is a good solution.

 
 
 
 


124 posts

Master Geek
+1 received by user: 1


  Reply # 297100 8-Feb-2010 16:49

Frittmann, the previous suggestion to temporarily disable any security on the wireless AP would at least eliminate those as possibilities. If it still doesn't work then you're looking at the config in Ubuntu. Linux used to be flaky with any wireless encryption but that seems to have been resolved in the past few years. FWIW I've found with a few recent distros that the network manager (under KDE at least) has problems with hidden AP's; un-hiding the AP, establishing the connection once then re-hiding the AP has worked - although from the screenshots you have posted, it looks like it is actually associating.

IG



65 posts

Master Geek
+1 received by user: 1


  Reply # 297113 8-Feb-2010 17:24
Send private message

Thanks soleil24, but once again, I'll wait for someone to suggest a solution to the problem, rather than possibly creating extra problems. The WiFi security settings are working perfectly under Windows, so I am not touching them. As I mentioned to CYaBro, I could have come up with that suggestion myself, but this appears to be a Linux problem, and not a pure networking problem. I can output the results of any diagnostics that may help resolve this. For instance, please see this post for the output of a dhclient wlan0 command, and an ifconfig command.

I'm using the Gnome desktop, so unless someone can verify that the problem with hidden SSIDs (mentioned above by soleil24) applies to Gnome as well as KDE, I would prefer to avoid messing with my AP.

124 posts

Master Geek
+1 received by user: 1


  Reply # 297119 8-Feb-2010 17:42

OK, fired up another laptop with Ubu 9.10/Gnome & sees the hidden AP fine and gets DHCP with wpa encryption...so looks like your wlan config, and could well be the 2 wlan's you refer to in the other post.

Isn't there a native Linux driver for the realtek? You could then eliminate the ndiswrapper layer.

You might want to wait for an Ubuntu networking expert but if it were me, I'd delete the entry for the wlan hardware device and see if the native driver/firmware isn't available and re-install the device with that. You should end up with just one wlan device listed in ifconfig (unless of course you really do have 2 !)

IG




65 posts

Master Geek
+1 received by user: 1


  Reply # 297125 8-Feb-2010 18:02
Send private message

Thanks for checking on that soleil24. As I said right at the start of this, I'm only just beginning to learn Linux networking. I read somewhere that there is a problem with the native Realtek RTL8185 drivers when using Ubuntu v8.04LTS, and that is why I'm using the ndiswrapper. If you can suggest a different driver that works with Hardy, I'd happily try it out. Preferably one that I don't need to compile myself. ;)

As for the two wlan entries, I have learned since that the "avahi" one is for Zeroconfig, and it is likely to be supplying the 169.254.x.x address. Anyone out there with experience in disabling Zeroconfig, or is there a reason why I shouldn't disable it? This is not something that I have had to use before in Windows.

124 posts

Master Geek
+1 received by user: 1


  Reply # 298045 11-Feb-2010 17:38

AFAIK Zeroconfig should only happen if a "real" IP address is not available(either static or dhcp) to at least enable local loopback. In which case the primary cause (not getting a dhcp ip) is giving you the zeroconfig instead.

As no one else is joining in, if you can wait till after the w/e I'll throw together an Ubu install again so I can look first hand (been a Suse & Fedora user for years but Ubuntu tries to do things so differently it's not worth trying to make too many generic suggestions !).

IG

137 posts

Master Geek
Inactive user


  Reply # 298057 11-Feb-2010 18:14
Send private message

Hey, yea... I see what you mean about the drivers... anyways, I'd definately recommend getting the OEM drivers, since they are available, at least then you can hassle RealTek for support ;P

It's linux... Open Source... get used to it sooner rather than later and figure out how to compile stuff. You'll be a much better linux user for it.

Since it looks like a driver prob here's an alternative... go to a computer retailer and tell them you need a wireless card for Linux, preferably PCI/PCIe... if it works then yay, sell the Realtek to a Windows user. If not take it back under the CGA.

124 posts

Master Geek
+1 received by user: 1


  Reply # 298876 14-Feb-2010 16:10

Looks to me as if the rtl8180 driver will do the job for this chipset and that should be included in the kernel of LTS8.04.

So you don't need to be using ndiswrapper, nor do you need to be worrying about compiling drivers from source (not that doing so is a big deal and as JDNZ suggests, something you may have to get used to, using any Linux !)

Be tempted to undo the ndiswrapper setup, then see if the install will "automagically" assign the rtl8180 kernel driver for your hardware and then re-do your wireless settings (assigning SSID and WEP key). If not then get hold of the driver from realtek & go down the compile, install route. This might help.

ndiswrapper should be a last resort if no native linux driver is avaailable (imho Smile)

IG

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

UAV Traffic Management Trial launching today in New Zealand
Posted 12-Dec-2017 16:06


UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23


New Fujifilm macro lens lands in New Zealand
Posted 5-Dec-2017 20:16


Cyber security not being taken seriously enough
Posted 5-Dec-2017 20:13


Sony commences Android 8.0 Oreo rollout in New Zealand
Posted 5-Dec-2017 20:08



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.