Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




5 posts

Wannabe Geek


# 128929 28-Aug-2013 18:58
Send private message

I have just got Telecom UFB installed and would like to use an old 1841 router that I have lying around. I have tried to setup PPPOE but struggling a little and not sure where my issue is. Does anyone have a cisco config that works, so that I can see what I have missed.

Thanks in advance.

Create new topic
3352 posts

Uber Geek


  # 886127 28-Aug-2013 19:59
Send private message

Search SRP521W...

Few examples around. Seems you need to make a sup-if with DHCP assignment and Vlan10 tagging

1948 posts

Uber Geek
Inactive user


  # 886161 28-Aug-2013 20:42
Send private message

I've set this up on a 1721 before, the trick is you need a 12.4 "T" IOS firmware otherwise you couldn't have the pppoe-client inside the vlan, that caught me out for a while and may be the same on your 1841 depending on how old the IOS on it is.

https://supportforums.cisco.com/thread/2146415

Then this will sort you out most of the way:

https://supportforums.cisco.com/thread/2100141

interface FastEthernet0/0
description WAN
no ip address
duplex auto
speed auto

interface FastEthernet0/0.10
encapsulation dot1Q 10
pppoe enable group global
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
dialer idle-timeout 0
dialer persistent
ppp authentication pap
ppp pap sent-username user@xtrabb.co.nz password 0 password

ip nat inside source list 1 interface Dialer0 overload
access-list 1 remark The local LAN.
access-list 1 permit 192.168.1.0 0.0.0.255

Or something along those lines, my 1721 router is at work that I used for a UFB setup so I will dig it out and power it on and grab the config for you tomorrow if the above doesn't get you going.

 
 
 
 




5 posts

Wannabe Geek


  # 886170 28-Aug-2013 21:01
One person supports this post
Send private message

Thanks, just checked my firmware and it is missing the "T" will get my hand on the correct firmware and give it another go.



5 posts

Wannabe Geek


  # 887200 30-Aug-2013 20:17
One person supports this post
Send private message

In case anyone else has the same issues as me, a combination of things to solve the problem.

Thanks to plambrechtsen for getting me passed my hurdle with the firmware version. Does require a "T" version, to have the pppoe-client command inside a sub interface. Below is the config I required to get my Cisco router on the Telcom UFB with PPPOE.


interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto

interface FastEthernet0/0.10
encapsulation dot1Q 10
pppoe enable group global
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1

ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload
!
ip access-list extended DSL_ACCESSLIST
permit ip 192.168.0.0 0.0.255.255 any
!
dialer-list 1 protocol ip permit

1948 posts

Uber Geek
Inactive user


  # 887715 1-Sep-2013 09:53
Send private message

AtomixNZ: In case anyone else has the same issues as me, a combination of things to solve the problem.

Thanks to plambrechtsen for getting me passed my hurdle with the firmware version. Does require a "T" version, to have the pppoe-client command inside a sub interface. Below is the config I required to get my Cisco router on the Telcom UFB with PPPOE.


Sweeeet.. Glad you're sorted :)

1 post

Wannabe Geek


  # 940525 25-Nov-2013 18:13
Send private message

After much tutu-ing, I could not get mine to establish a layer 2 connection.

Here is my config, I can get some action with the debug ppp commands, but I didn't copy any of it and I'm not able to go back on site until I have a working config. So I know there is at least some communication:


interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication pap
ppp pap sent-username user@xtrabb.co.nz password 7 06160E325F59060B01
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat source static tcp 192.168.1.2 3389 interface Dialer1 3389
ip nat source static tcp 192.168.1.200 23 interface Dialer1 23
ip nat inside source list UFB.NAT.INSIDE.IPs interface Dialer1 overload
!
ip access-list standard UFB.NAT.INSIDE.IPs
permit 192.168.1.0 0.0.0.255
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit


I don't see how it is any different from what the both of you posted, and I'm using Adv-Ent 12.4 22 T7.
Any ideas?



5 posts

Wannabe Geek


  # 940579 25-Nov-2013 19:22
Send private message

Hi,

I noticed that you have set the username and password, when I tried this I could not get a connection. I had to remove these lines from my config and then it was all ok.

Hope this helps.



Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36


MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28


Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15


D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31


Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36


2degrees Reaches Milestone of 100,000 Broadband Customers
Posted 1-Oct-2019 09:17


Nokia 1 Plus available in New Zealand from 2nd October
Posted 30-Sep-2019 17:46


Ola integrates Apple Pay as payment method in New Zealand
Posted 25-Sep-2019 09:51


Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.