Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




7 posts

Wannabe Geek


Topic # 14870 24-Jul-2007 18:08
Send private message

I need some help with my wireless connection. I have a Dlink DSL 502 connected to Xtra and a netgear WGR614v7 wireless  router. When connected directly to the modem the internet works fine, I can connect wirelessly to the router. But can not connect to the internet through the wireless router. also if i have a cable between my laptop and router it works fine. If this makes sense.... So the problem is i can't connect wirelessly to the internet. I think it might be a IP or DNS problem cause i have no idea what these should be set at for my laptop, wireless router and modem.

Please help
thanks
Gareth

Create new topic
Hawkes Bay
8477 posts

Uber Geek
+1 received by user: 5

Mod Emeritus
Trusted
Lifetime subscriber

  Reply # 79473 24-Jul-2007 19:04
Send private message

are you using DHCP?
are you using WEP?
are you using WPA? (and does your laptop support it)









7 posts

Wannabe Geek


  Reply # 79525 25-Jul-2007 01:08
Send private message

I am using WEP 64bit because one of the laptops (not mine) can not support WPA. I am not sure how to use DHCP when i use ipconfig/all it says DHCP is enabled

 
 
 
 


4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 79563 25-Jul-2007 11:04
Send private message

Have you enabled DHCP on the rotuer? (Automatically assign IP address)



7 posts

Wannabe Geek


  Reply # 79577 25-Jul-2007 11:43
Send private message

My router is running DHCP and its
ip 192.168.1.1
subnet 255.255.255.0

the modem is also running as a DHCP router but has
ip 10.1.1.1
subnet 255.0.0.0

Is this the problem? I have tried changing the ip settings on the modem but it seems to crash every time should i just change them on the router? or is it a conflict between the modem and router both running as DHCP routers?


4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 79580 25-Jul-2007 11:59
Send private message

I would recommend that you manually assign them on the modem. And only use your router to be the DHCP device.

What is the IP address your wireless connection gets assigned?


Hawkes Bay
8477 posts

Uber Geek
+1 received by user: 5

Mod Emeritus
Trusted
Lifetime subscriber

  Reply # 79590 25-Jul-2007 12:46
Send private message

same as above.

set modem to 192.168.0.1 255.255.255.0 dhcp disabled
set router wan to 192.168.0.2 255.255.255.0 (manually assigned IP address)
make the internal lan on the router something like 192.168.1.1 255.255.255.0 with the dhcp server enabled
set the DHCP range to something like 192.168.1.10 to 192.168.1.99

put a sticky label on each device (modem and router) with the ip you assigned.

any client PCs now should connect with DHCP in the address range indicated. If you need to add anymore networking devices, assign static ips at the low end of the range, and client PCs that need static from 192.168.1.100 and up. Then its all nice and organised.










7 posts

Wannabe Geek


  Reply # 79620 25-Jul-2007 15:12
Send private message

Thanks alot for the help.

I still cant change the IP settings on the modem without it crashing. Also adjusting the WAN settings on the router under "WAN setup" i have 4 options
connect automatically, as required
Disable SPI firewall
Default DMZ Server 192.168.1. and the last number is adjustable but currently set at 1
Respond to ping on internet port

currently only connect automatically is selected
or should i be adjusting the ip under internet ip address.

Also what should the DNS and gateway ip be set on my computer

4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 79622 25-Jul-2007 15:16
Send private message

If your modem still crashes, then I suggest reseting it, or updating its firmware.

The gateway on your PC, will be the IP address of the router. Also the DNS settings you can get automatically from the rotuer, or you will have been provided with them by your ISP.

They may be on your modem at the moment?



7 posts

Wannabe Geek


  Reply # 79623 25-Jul-2007 15:23
Send private message

i have just managed to update the modem ip to 192.168.0.1
but i still cant / dont know where to change the router WAN IP

6 posts

Wannabe Geek


  Reply # 79732 26-Jul-2007 09:50
Send private message

Easy way for this is

Leave the IP address of your DSL modem as it is and turn off DHCP on wireless router (which makes it act like a switch), make sure you choose WEP or WPA security on the wireless router.





339 posts

Ultimate Geek
+1 received by user: 25

Trusted

  Reply # 79952 27-Jul-2007 10:37
Send private message

First up, you have the modem plugged into the internet port of the netgeasr router right?
If so, you should be able to plug everything in, connect to the wireless router, and everything should just go.
One thing to do is (if your dlink firmware supports it) is to set your modem to half-bridge or half-ppp mode. This basically passes the ADSL connection directly to the netgear router, and you have the internet DNS settings and username settings put into the wireless router instead. This sorts out the headaches you have of trying to work with two NAT routers, as putting the modem into half-bridge mode will automatically turn of its NAT function.
If you do decide to do this though, you will need to restart your routers in the proper sequence. umplug the modem and netgear router. then plug in the dlink modem, and WAIT UNTIL ADSL HAD CONNECTED. Then plug in the netgear router. the internet light on the netgear router should be orange, and then eventually turn green. Once it has turned green, you SHOULD be able to connect to the internet via wireless.
If you can't put the dlink into half-bridge mode, then reset both the dlink router and netgear router to factory defaults. Put your username settings into the dslink, and reconfigure your netgear for wireless. There should be no need to mess with IP addresses - both routers should sort things out between them and you should be able to connect to the internet via the netgear router.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.