Like many others it seems, my Palm Web Pro 3.0.1 is failing to display web pages and giving the message:

'DNS lookup timed out. Please check coverage and try again (Comm. 8)'

This happens when my brand new PalmOne T3 with PalmOne Wi-Fi card tries to make a connection to the internet via my own Apple Airport Base Station, but if the connection is already made (via my desktop iMac) then the T3's Web Pro works perfectly.

I have entered my Airport's WEP 'equivalent network password' into the T3 as '40-bit hex'.
The status of 'Use proxy server' in Web Pro's Preferences menu makes no difference.
I have manually entered the Airport's DNS numbers into the T3.

Am I expecting too much from the T3? Is it capable of instructing the Airport Base Station to dial my ISP?

However, the problem isn't confined to Airport. When "roaming", the T3's Wi-Fi identified a public site, displayed something like "Receiving IP address" but never completed the operation. It also gave the same error message (DNS lookup timed out. Please check coverage and try again (Comm. 8)) when within range of my friend's Broadband router until I entered the 'Pref. DNS' number manually. Then Web Pro worked except it would not display www.google.co.uk, saying that the host did not exist!

Has no-one else had similar problems with Wi-Fi?