Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




12 posts

Geek


# 177858 16-Aug-2015 16:52
Send private message

Cannot access some HTTP:// sites from within a standard virtual machine on Orcon.

Orcon UFB under UFF (Hamilton)
Orcon "white" NF4V

Apart from a couple of port forwards (and therefore admin interface on LAN port 8080), left basically standard.

On a machine in the network.
Windows 10 pro virgin install.
Hyper-V
Single "external virtual switch", no vlan tagging.
Windows 2012 trial (from Microsoft's VHD)

- gets it's ip VIA DHCP from the NF4V (reserved by MAC address)
Regardless of browser, On the W2012 I can access only some internet HTTP:// websites.

eg:      Cannot access www.bing.com, but can access https://www.bing.com
    Can access http://www.google.com and https://www.google.com

The host machine can access any of these sites.


Tried:
I've turned off smartscreen, browser protection, etc.
opened, and even disabled the W2012 firewall.
Switched to VMWARE player.
Switched to a different host (A Win7 one).
Configured windows on the VM to use a proxy (and set up CCproxy on another host in the network).  This works, but does not solve my problem.
Set the VM to use the host's WIFI, and tethered to my mobile phone.  This worked too but does not solve my problem.
Messed with many settings on the NF4V, but set them back when nothing worked.
Called Orcon.  They said "Virtual networks / machines are not supported".

Create new topic
252 posts

Ultimate Geek


  # 1367716 17-Aug-2015 08:13
Send private message

Something may be interfering with unencrypted traffic (have you got any firewall or antivirus installed - try disabling it, perhaps a browser plug in might be causing it).  Have you tried a different browser like Chrome or Firefox?






Try my latest project, a Cisco type 5 enable secret password cracker written in javascript!

3344 posts

Uber Geek

Trusted
Vocus

  # 1367739 17-Aug-2015 09:13
Send private message

Sounds like maybe IE Enhanced Security Configuration.  Why you want to browse from a Server install anyway?

 
 
 
 


252 posts

Ultimate Geek


  # 1367741 17-Aug-2015 09:16
Send private message

I just spotted you mentioned VMWare player.  Have you installed the VMWare guest components?




Try my latest project, a Cisco type 5 enable secret password cracker written in javascript!



12 posts

Geek


  # 1368197 17-Aug-2015 21:20
Send private message


Hi there, thanks so much for your help.

Yes, enhanced security is off.  Note that the same problem occurs when I try to use Curl, or even telnet to these sites and manually perform a HTTP/GET from within the guest.  It just times out.

The current system is Hyper-V and was built on it - no VMware tools are or have-been installed on the guest OS.

Things tried today were to hard-set the host and guests' IP settings (rather than Reserved DHCP). - It didn't work.
Also tried disabling the port 80 forward ("virtual server") on the router.  It didn't help either.
Note that When I set the host machine to use wifi tethered to my mobile - access was normal.
when I use WIFI to connect to my Orcon router however, the problem occurred also.
Oh.  I'm using win2012 because I'm testing a server-class Application.

Next I may need to take to host to some other network, or start network sniffing.





3344 posts

Uber Geek

Trusted
Vocus

  # 1374885 26-Aug-2015 21:22
Send private message

Did you get to the bottom of this?  Curious what it was...



12 posts

Geek


  # 1375355 27-Aug-2015 18:15
Send private message

No, I didn't.  Though literature suggests it may be somehow related to IP fragmenting and MTU. 

I've been a bit busy at work, and will pick it up again when I get a chance.

252 posts

Ultimate Geek


  # 1375361 27-Aug-2015 18:33
Send private message

Have a look at this article and verify if your MTU is 1500 bytes.  If it is, try reducing it to 1400 and see if the problem remains.  This might very well be an MTU squeeze.
http://blogs.technet.com/b/askpfeplat/archive/2014/12/01/psa-incorrect-mtu-size-causes-connectivity-issues-with-windows-server-2012-and-windows-server-2012-r2.aspx




Try my latest project, a Cisco type 5 enable secret password cracker written in javascript!

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29


Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21


New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.