I was wondering if someone could help me out. I have a 2 Dell PC's running Windows XP Home on my internal network.

I am using a DSL modem to go online, and that is connected to a router, which my 2 PC's are networked in. The internal address is 10.0.0.x

Today I replaced one PC with a brand new Dell PC, and noticed I could not surf the web after hooking everything up. I received a DHCP IP address, which gives me the following:

IP -
Subnet -
Gateway -

I am able to ping the other PC in the network, and vice versa. I shutdown all Firewall options, and Anti Spam. I noticed I cannot goto www.google.com, however, I can access it by typing the actual IP address

This leads me to think that there is something wrong with DNS, am I correct? i also tried to assign a static IP, and I get the same results.

I ran the following:
ipconfig /release
ipconfig /renew
ipconfig /flushdns
ipconfig /registerdns
ipconfig /displaydns

tracert (Successful)
tracert www.google.com (Unsuccessful)

I also tried hooking up the same cable to the old PC, and was able to go online without any issues.

Does anyone have any thoughts??