Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




19 posts

Geek


Topic # 242489 30-Oct-2018 19:48
Send private message

I am trying to RDP to my PC over the internet however the connection is timing out because of no response from the remote device.

 

*gasp* Yes, I'm aware this is pretty stupid but this is only a short term thing, in the long term I'll get a VPN set up but I'm happy to accept the risks for now.

 

The router (Asus RT-AC58U) connects directly to the ONT while the PC I am trying to RDP to connected to one of the LAN ports on the router.

 

I have a Gigabit UFB connection with Skinny. To the best of my knowledge Skinny are no longer using CG NAT as the WAN IP of my router is the same IP I get when I enter what's my IP on Google from my PC.

 

I have configured Port Forwading/Destination PAT (WAN address:5555 --> 192.168.1.30:3389) as per below 

 

Click to see full size

 

I tested on various port forward checking websites and it's showing the connection as closed/filtered.

 

 

 

Troubleshooting done so far :

 

- When an RDP connection is made from an external device on the internet, in this case from a 2degrees 4G connection, from the connection logs I can see on the Asus router, it appears to be allowing the inbound TCP connection as per below

 

Oct 30 18:37:29 kernel: ACCEPT IN=ppp0 OUT=br0 MAC= SRC=118.148.x.x DST=192.168.1.30 LEN=64 TOS=0x00 PREC=0x00 TTL=248 ID=48485 DF PROTO=TCP SPT=11138 DPT=3389 SEQ=728927993 ACK=0 WINDOW=4380 RES=0x00 SYN URGP=0 OPT (020405AC010303030101080AC3B100AB0000000004020000)
Oct 30 18:37:32 kernel: ACCEPT IN=ppp0 OUT=br0 MAC= SRC=118.148.x.x DST=192.168.1.30 LEN=64 TOS=0x00 PREC=0x00 TTL=248 ID=2910 DF PROTO=TCP SPT=11138 DPT=3389 SEQ=728927993 ACK=0 WINDOW=4380 RES=0x00 SYN URGP=0 OPT (020405AC010303030101080AC3B10C630000000004020000)
Oct 30 18:37:35 kernel: ACCEPT IN=ppp0 OUT=br0 MAC= SRC=118.148.x.x DST=192.168.1.30 LEN=64 TOS=0x00 PREC=0x00 TTL=248 ID=41649 DF PROTO=TCP SPT=11138 DPT=3389 SEQ=728927993 ACK=0 WINDOW=4380 RES=0x00 SYN URGP=0 OPT (020405AC010303030101080AC3B1181B0000000004020000)
Oct 30 18:37:38 kernel: ACCEPT IN=ppp0 OUT=br0 MAC= SRC=118.148.x.x DST=192.168.1.30 LEN=48 TOS=0x00 PREC=0x00 TTL=248 ID=50754 DF PROTO=TCP SPT=11138 DPT=3389 SEQ=728927993 ACK=0 WINDOW=4380 RES=0x00 SYN URGP=0 OPT (020405AC04020000)

 

 

 

- Turned off Windows Firewall/Defender

 

- Tried using other external ports - 3389, 5150, 7777, etc

 

- Confirmed inbound RDP is enabled on the PC

 

Click to see full size

 

- Confirmed port TCP 3389 on the PC is listening

 

Click to see full size

 


- Ran a Wireshark capture on the PC when making a connection attempt; I do not see any inbound RDP traffic at all

 

 

 

From what I gather the inbound traffic is getting past the firewall but for some reason never arrives at the destination. I'd appreciate any advice to troubleshoot this further.


Create new topic
785 posts

Ultimate Geek
+1 received by user: 236


  Reply # 2117101 30-Oct-2018 20:39
One person supports this post
Send private message

Make sure RDP is allowed through the windows firewall.

 

Does RDP work when you are in the same lan?

 

John





I know enough to be dangerous


162 posts

Master Geek
+1 received by user: 21


  Reply # 2117102 30-Oct-2018 20:40
One person supports this post
Send private message

I have found that sometimes when there is an intermittent problem, just re-entering the saved password will make it work.

 

Is it possible the IP address has changed?

 

Good Luck


 
 
 
 


4290 posts

Uber Geek
+1 received by user: 622

Trusted

  Reply # 2117104 30-Oct-2018 20:42
One person supports this post
Send private message

Is that saying source port 11138?




Previously known as psycik

OpenHAB: Gigabyte AMD A8 BrixOpenHAB with Aeotech ZWave Controller, Raspberry PI, Wemos D1 Mini, Zwave, Xiaomi Humidity and Temperature sensors and Bluetooth LE Sensors
Media:Chromecast v2, ATV4, Roku3, HDHomeRun Dual
Windows 10
Host (Plex Server/Crashplan): 2x2TB, 2x3TB, 1x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 1xW2k8, 2xUbuntu 16.04 LTS, Crashplan, NextPVR channel for Plex,NextPVR Metadata Agent and Scanner for Plex


Mr Snotty
8417 posts

Uber Geek
+1 received by user: 4343

Moderator
Trusted
Lifetime subscriber

  Reply # 2117120 30-Oct-2018 21:18
2 people support this post
Send private message

Instead of doing that and opening yourself up (even if it is just for a short time) give Anydesk a go: https://anydesk.com/remote-desktop

 

Tree, tiny, works fast and is secure. Doesn't require you to open any ports etc and works through the harshest of firewalls.

 

I have it running as a service on my parents laptop and have a 100% success rate with logging in.







19 posts

Geek


  Reply # 2117131 30-Oct-2018 21:53
Send private message

SATTV:

 

Make sure RDP is allowed through the windows firewall.

 

Does RDP work when you are in the same lan?

 

John

 

 

Yep I have added a rule on the Windows firewall and also tried with the firewall on and off. I am able to RDP to it from another device in the same network (192.168.1.0/24).

 

Yogi02:

 

I have found that sometimes when there is an intermittent problem, just re-entering the saved password will make it work.

 

Is it possible the IP address has changed?

 

Good Luck

 

 

Yep I am definitely trying to RDP to the correct public/WAN IP address. I have verified this in the router.

 

I have statically configured the IP address 192.168.1.30 on my PC.

 

I never get a prompt to enter the user name and password when trying to RDP, it just eventually times out because of no response from the remote end.

 

davidcole: Is that saying source port 11138?

 

That is the source port which is randomly generated. I tried connecting again and it used a different source port. The destination port is 3389.

 

michaelmurfy:

 

Instead of doing that and opening yourself up (even if it is just for a short time) give Anydesk a go: https://anydesk.com/remote-desktop

 

Tree, tiny, works fast and is secure. Doesn't require you to open any ports etc and works through the harshest of firewalls.

 

I have it running as a service on my parents laptop and have a 100% success rate with logging in.

 

 

Thanks for the suggestion, I'll check it out now. Do you know if it supports wake on LAN?


xpd

Chief Trash Bandit
9359 posts

Uber Geek
+1 received by user: 1562

Mod Emeritus
Trusted
Lifetime subscriber

  Reply # 2117171 31-Oct-2018 07:36
Send private message

I use Anydesk every day, great product. 

 

As for WOL, I dont think it does.

 

 

 

 





XPD / Gavin / DemiseNZ

 

Server : i3-3240 @ 3.40GHz  16GB RAM  Win 10 Pro    Workstation : i5-3570K @ 3.40GHz  16GB RAM  RX580 4GB Win 10 Pro    Console : Xbox One

 

https://www.xpd.co.nz - Games, geeks, and more.    


4033 posts

Uber Geek
+1 received by user: 1352


  Reply # 2117178 31-Oct-2018 08:07
Send private message

It should be working and you have done most of the things I'd have tried. 

 

So, something is conflicting in either the router or in windows.

 

Reset your router to factory settings, and reconfigure port forwarding. 

 

 

 

Then try resetting your windows networking...

 

     

  1. Select the Start  button, then select Settings  > Network & Internet  > Status > Network reset.
  2. On the Network reset screen, select Reset now > Yes to confirm.

     

    Wait for your PC to restart and see if that fixes the problem.

     

 

 

 

 

 

Can you run a DMZ test? Or possibly reinstall windows if it is an old installation could be messed up. 

 

 

 

 




19 posts

Geek


Reply # 2117190 31-Oct-2018 08:27
Send private message

surfisup1000:

 

It should be working and you have done most of the things I'd have tried. 

 

So, something is conflicting in either the router or in windows.

 

Reset your router to factory settings, and reconfigure port forwarding. 

 

 

 

Then try resetting your windows networking...

 

     

  1. Select the Start  button, then select Settings  > Network & Internet  > Status > Network reset.
  2. On the Network reset screen, select Reset now > Yes to confirm.

     

    Wait for your PC to restart and see if that fixes the problem.

     

 

 

 

Can you run a DMZ test? Or possibly reinstall windows if it is an old installation could be messed up. 

 

 

 

 

 

 

 

 

I only had a few minutes to spare this morning before work so didn't have time to do a factory reset but thanks for reminding me about the DMZ feature on the Asus router. I placed my PC in the DMZ and was able to RDP to it over the internet finally. When I removed it from the DMZ I was still able to RDP to it so all is well now kiss

 

Hooray for consumer grade junk eh.


Mr Snotty
8417 posts

Uber Geek
+1 received by user: 4343

Moderator
Trusted
Lifetime subscriber

  Reply # 2117192 31-Oct-2018 08:32
Send private message

Just remember with DMZ you're exposing your whole PC to the internet. If it is not if, it is when to it being pwned.





4033 posts

Uber Geek
+1 received by user: 1352


  Reply # 2117236 31-Oct-2018 09:01
Send private message

michaelmurfy:

 

Just remember with DMZ you're exposing your whole PC to the internet. If it is not if, it is when to it being pwned.

 

 

Yes, that is true. 

 

But I suppose this proves that it is the router or router config which is causing the problem.

 

I would think exposing RDP ports is probably a huge risk anyway.  I used to do this years ago, but i was getting some events in my event log that looked like someone had gained access to my machine. 

 

 

 

 


3033 posts

Uber Geek
+1 received by user: 299


  Reply # 2117237 31-Oct-2018 09:03
One person supports this post
Send private message

And if you do get it working I would definitely put something like Duo on there for 2FA.

 

It's free!


Create new topic


Donate via Givealittle


Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

A call from the companies providing internet access for the great majority of New Zealanders, to the companies with the greatest influence over social media content
Posted 19-Mar-2019 15:21


Two e-scooter companies selected for Wellington trial
Posted 15-Mar-2019 17:33


GeForce GTX 1660 available now
Posted 15-Mar-2019 08:47


Artificial Intelligence to double the rate of innovation in New Zealand by 2021
Posted 13-Mar-2019 14:47


LG demonstrates smart home concepts at LG InnoFest
Posted 13-Mar-2019 14:45


New Zealanders buying more expensive smartphones
Posted 11-Mar-2019 09:52


2degrees Offers Amazon Prime Video to Broadband Customers
Posted 8-Mar-2019 14:10


D-Link ANZ launches D-Fend AC2600 Wi-Fi Router Protected by McAfee
Posted 7-Mar-2019 11:09


Slingshot commissions celebrities to design new modems
Posted 5-Mar-2019 08:58


Symantec Annual Threat Report reveals more ambitious, destructive and stealthy attacks
Posted 28-Feb-2019 10:14


FUJIFILM launches high performing X-T30
Posted 28-Feb-2019 09:40


Netflix is killing content piracy says research
Posted 28-Feb-2019 09:33


Trend Micro finds shifting threats require kiwis to rethink security priorities
Posted 28-Feb-2019 09:27


Mainfreight uses Spark IoT Asset Tracking service
Posted 28-Feb-2019 09:25


Spark IoT network now covers 98% of New Zealand population
Posted 19-Feb-2019 09:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.