Heya Dudes,


i have this d..n Event ID: 18 too and it's annoying: no more phone conny possible since the problem starts..
so i started a massive debug/tracing/google overkill to get the following reasons and maybe resolutions:

here some of the possible reasons:

Security Update for Windows XP (KB951376-v2, MS08-030) :

MS08-030: Vulnerability in Bluetooth stack could allow remote code execution

http://www.microsoft.com/downloads/details.aspx?familyid=980BB421-950F-4825-8039-44CC961A47B8&displaylang=en

http://support.microsoft.com/kb/951376

This funny thing comes over winupdate arround 6/19/2008 and owned my bthport.sys from
version 5.1.2600.5512 to 5.1.2600.5620.

You can check %WINDIR%\$NtUninstallKB951376-v2$ or better: do a recursive search from your systemdrive root (C:\)
for: bthport (with showing hidden and systemfiles)... amazing...

The problem results of incorrect registry permissions inside:

"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTHPORT"



So i picked up my RegWorkshop (best regedit replacement!!!) to start some snapshot/snapshot and compare sessions..
As i entered the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTHPORT\Parameters\ subkey
i noticed a red marked "keys" subkey... Access Denied comes over me while clicking into it...

So i tried to change the perms... whoa.. my tool told me that the acl's on this keys are corrupt/incorrect...
Now i tried to reset them to default...and unbelieveable : after reboot i got my com-port buddies back and i can browse
and auth my bt-dev's ;)

Only the real connection to the attached devices is'nt possible.. maybe the tools can't connect to the virtual comports
over the new bt-stack sponsored by M$ :|
(NOTE: there must be minimum 1 incoming and 1 outgoing serial port appear after the btDongle insert)


My Tip: fix the acl's as explained above, remove all bth* ; oem* (maybe temporally) from your %WINDIR%\inf folders.
Check the BthServ service (must be running in some cases, depends on btDongle types).
Now give'em a reboot and try again...

Tip: Try another usb-port, so windoze reinitialize the driver classes from a fresh state: be sure that the dongle never plugged in before: exept when it was a working well state !!!

My hardest way these days : i've captured the registry/file additions/changes with regworkshop and installwatch on a clean installed xp sp2 machine to copy/migrate this into my problem comp... no success...

Then i've made a .reg file negotation file which removed all bt relevant settings, keys, services... BSOD... hehe...
i'am still on this and keep ya updated...

BUT: we're not alone with our Event18 kiddie:

http://www.google.com/search?hl=en&as_q=&as_epq=KB951376+v2&as_oq=&as_eq=&num=100&lr=&as_filetype=&ft=i&as_sitesearch=&as_qdr=all&as_rights=&as_occt=any&cr=&as_nlo=&as_nhi=&safe=images


Another "candidate" (maybe) is the toshiba bt stack... untested but i've found some oem0x-files arround my inf folders...


Let me know when this info was helpful or if there are any other workarrounds

regards and greetz from Germany, dracid