Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


5 posts

Wannabe Geek


Topic # 29620 13-Jan-2009 14:10
Send private message

I live above a pub and have access to free internet (can't complain) and have decided to set up a wireless router so i can connect my PS3 and laptop as well as my desktop. After a little homework i purchased a TP-Link wireless router to do the job. Up until now i have had an ethernet cable running from the modem in the bar to my flat without a problem, other than having to unplug the ethernet cable every time i want to switch between computers. I assume the router is the problem because as soon as I plug the ethernet cable directly into the computer I get a perfect connection.
I connected the router today and followed all instructions but it will not connect to the internet. There is a message saying "obtaining network parameters" which just won't go away. Does anyone know what i need to do to fix this as it's driving me crazy. I have tried the recomended power cycle but still no luck. Any help would be appreciated as i don't have that much hair left to loose!

Create new topic
75 posts

Master Geek


  Reply # 189228 13-Jan-2009 15:00
Send private message

Sounds like your PC is looking for a DHCP server which isn't enabled on the TP-Link router.  It could also be complicated if you have connected the WAN interface on the TP-Link to the LAN interface on the aDSL router.  This means you have two routers between you and the internet, and configuring them correctly is much trickier than simply putting them on the same LAN segment.

Try connecting the LAN port on the aDSL router to a LAN port on the wireless router.  Disable all router/DHCP/DNS server functions on the TP-Link wireless router, and use the DHCP server from the aDSL modem.  Make sure the aDSL router is configured as a DHCP server, and that its own LAN interface, and the LAN interface on the TP Link (if it can't be configured as a DHCP client) are configured to be in the same subnet.



5 posts

Wannabe Geek


  Reply # 189238 13-Jan-2009 15:18
Send private message

Would an access point, rather than a router do away with all this?


75 posts

Master Geek


  Reply # 189242 13-Jan-2009 15:27
Send private message

Not really.  Most of the time, wireless access point is just another name for a wireless router.  Both have 802.11 interfaces (wireless), and most have a 802.3 LAN and a 802.3 WAN port.

Most wireless access points, have the LAN/wireless interfaces configured as a single subnet.  This means they are all part of the same "network".  As soon as you start connecting things via the WAN interface, the device treats it as a seperate "network" and there are different rules about how it has to be configured.

As mentioned, the easiest way, is to leave the aDSL router configured as it was.  Give the TP-Link LAN interface a static IP address in the same subnet as the aDSL LAN interface.  Disable DHCP, DNS, and any other server functions on the TP-Link.  This will create a single subnet inside the aDSL router, and the rest of the world outside the router.

It sounds like the aDSL router is configured as a DHCP server on the LAN interface, and your PC is a DHCP client.  As long as your TP-Link router LAN interface, PC wireless interface, and the aDSL LAN interface are all within the same subnet, you should get a DHCP address fine, and everyone should be happy.



5 posts

Wannabe Geek


  Reply # 189243 13-Jan-2009 15:33
Send private message

Wow! my head hurts. Thanks for your advice, i'll try and muddle through this and see if i have any luck. Any chance i could have that explanation in crayon?

1984 posts

Uber Geek
+1 received by user: 133

Trusted

  Reply # 190083 16-Jan-2009 23:39
Send private message

Yes, an Access Point would solve the configuration problem because everything is on the same LAN, but you need ethernet ports too and any device still needs correct subnet and gateway setup getting through to all computers (using DHCP of course). I recommend you let your router pickup the automatic (DHCP) IP address from the ADSL router, and turn off the NAT function. You might need to specify the pub router as the DHCP Relay server if switching off the DHCP causes any problems.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.