Hi all, wondering if anyone here has experienced this and may have some tips or feedback?


Problem: The Dream Router will lock up/crash/freeze - blue ring light is on, fan is going full speed, front display is completely blank. No connectivity even over LAN.


Workaround: Hard restart of the UDR, give it 5-10mins to boot




  • Chorus ONT


    • Unifi Dream Router (UniFi OS 3.1.14, Network app 7.4.162) 


      • Unifi USW-Flex-Mini 5 port Gig switch (Firmware 2.0.0)


        • Unifi UAP-FlexHD (Firmware 6.5.64)
        • TPLink 5 port unmanaged switch 


          • Another Unifi UAP-FlexHD (Firmware 6.5.64)

All devices are connected in the above order - mesh is disabled for the APs, and everything is powered via their included adaptors/PoE Injectors.


I purchased everything last week (except ONT and TPLink switch) from PBTech and it's been working flawlessly since. I was achieving line speed (300/100 ish give or take) via the router or the FlexHD APs for internet activity, local transfers much faster but not Gig which I expected anyway.


Last night I had my first problem, everything in the house lost connectivity just before bed time. I was more annoyed having to get up again to turn off all the lights manually - normally done via a Siri request to home assistant. 
That's when I saw the UDR showing the symptoms above. Hard reboot kicked it into gear, took about 5-10mins ish to finish booting before things were talking to each other once more. I raised a ticket with Ubiquity this morning to see if we could find out what happened and have yet to hear back.


It happened again this afternoon while downloading a large ISO file from Microsoft - I was getting around 250mbps over wifi and maybe 5GB into the download everything stopped. UDR doing the same behaviour. 


I rebooted the UDR, did the download again and got the same thing to happen. Each time it would do it quite late into the download rather than when it reached a certain speed for example.


Later on once I finally got the file, I tried to upload it from my Mac over WiFI to a Proxmox server on LAN via the Unifi switch, same thing again.




What I've tried so far:


  • Disabling PoE and moving all devices to their own adaptors. No change.
  • Forcing a WiFi device to specific APs or direct to UDR AP then retrying download. Same behaviour on any AP. 
  • Download from internet over LAN cable direct between UDR and PC. This worked, but unsure if the file download was just too quick to trigger the issue. 

Tomorrow Im going to do some more testing, perhaps LAN only file copies without using WiFi. 




But all of this is really just testing to see where the problem is introduced and may not actually resolve the problem. It seems like large downloads trigger the issue but I don't know for sure. Though last night I wasn't aware of any happening during the time it occurred (though it's possible the Arlo system was doing an upload, or one of our devices was auto updating something).


Anyone else experiencing this or got any tips? I've seen some posts online about it but they are going back several months/last year. I've only ever been on the firmware/OS versions listed above so have no history to base this on other than 11 days of bliss.