Hi there,

I have fujitsu Loox600 Poeckt PC and I am trying to connect this to my
PC using bluetooth.
I am running SuSe9.0 (Linux) on my PC and the bluetooth dongle is from CSR.

From the PC end the device is acting as a SLAVE.

I want to make my Pocket PC as Master, so for this I ran the PLUG FREE setup wizard for Bluetooth devices on Pocket PC, and enabled the Discover option.

Whan I tried to discover my Pocket PC using
"hcitool scan"
then it shows the address of my Pocket PC.

But whenever I try to connect by issuing following command I receive error

rfcomm connect 0

Can't Connect RFCOMM socket: Connection reset by peer

What am I missing here?

my hcid.conf (/etc/bluetooth/) does not have authentication enabled, do I require to enable this?

From another side (Pocket PC) if I set the bluetooth connection as bonded then it asks for the passkey & it accepts it well, but still I can't connect through
rfcomm connect 0 from my PC.

What should I do for this?

Any help will be highly appreciated.

Thanks & Regards