Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




7 posts

Wannabe Geek


Topic # 90033 13-Sep-2011 19:45
Send private message

Does anybody know how to network dos 6.22 and window xp?


I have been trying for a long time but can't seem to make it happen.  

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
2413 posts

Uber Geek
+1 received by user: 133


  Reply # 520631 13-Sep-2011 20:09
Send private message

Er network how? For TCP/IP-internets? Or filesharing?



7 posts

Wannabe Geek


  Reply # 520682 13-Sep-2011 21:15
Send private message

tcp/ip. It is for a cnc milling machine. I just need one folder shared so i can get the programs. I already have another machine doing it but cant get it working on this one

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software

gzt

9582 posts

Uber Geek
+1 received by user: 1400


  Reply # 520685 13-Sep-2011 21:23
Send private message

What is the current status? Can you ping 127.0.0.1?

gzt

9582 posts

Uber Geek
+1 received by user: 1400


  Reply # 520688 13-Sep-2011 21:26
Send private message

Also post your config.sys and autoexec.bat. They are used to load the network and filesharing drivers.



7 posts

Wannabe Geek


  Reply # 520693 13-Sep-2011 21:34
Send private message

It wont ping anything. Tryed it earlier today. Im still trying to get the drivers loaded.

Ill put the files on in the morning when i get back to work. But there all over the place as ive tryed everything. Would be better to start again


Im getting a error about the netbios not being loaded  

4301 posts

Uber Geek
+1 received by user: 790

Moderator
Trusted
Lifetime subscriber

  Reply # 520696 13-Sep-2011 21:39
Send private message

Wow this is a blast from the past!



7 posts

Wannabe Geek


  Reply # 520697 13-Sep-2011 21:41
Send private message

Yea it is lol. Im glad times have changed



7 posts

Wannabe Geek


  Reply # 520761 14-Sep-2011 08:18
Send private message

Here they are

AUTOEXEC.bat
@echo off

PROMPT $p$g
if exist c:\svm.exe c:\svm 3
PATH C:\NC\DRIVERS;C:\DOS;C:\CNC7
SET TEMP=C:\DOS
doskey
SET CAM=both
SET EDT=cnc7
set mouse=C:\NC\DRIVERS
C:\NC\DRIVERS\mouse.exe /Q
cd\cnc7
if exist cpu7kb.com cpu7kb
c:\net\net start
c:\net\smartdrv.exe
c:\net\net start
cnc7m4

CONFIG.sys



DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS X=D000-D100
DEVICE=C:\BOOT\IFSHLP.SYS
DOS=HIGH, UMB
STACKS 0,0
DEVICEHIGH=C:\DOS\INTERLNK.EXE
FILES=30
BUFFERS=30DEVICE=C:\NET\PROTMAN.DOS /I:C:\NET
device=c:\net\nemm.dos
device=C:\NET\workgrp.sys
DEVICE=C:\net\tcpdrv.dos /I:c:\net
device=c:\net\ne2000.dos
LASTDRIVE=Z

PROTOCOL.ini



[network.setup]
version=0x3110
netcard=my$driver,1,MY$DRIVER,1
transport=tcpip,TCPIP
lana0=my$driver,1,tcpip

[my$driver]
drivername=Ne2000$

[protman]
drivername=PROTMAN$
PRIORITY=MS$NDISHLP

[tcpip]
NBSessions=6
IPAddress0=192 168 1 11
SubNetMask0=255 255 255 0
DefaultGateway0=
DisableDHCP=1
DriverName=TCPIP$
BINDINGS=my$driver
LANABASE=0

3391 posts

Uber Geek
+1 received by user: 395

Trusted

  Reply # 520780 14-Sep-2011 09:13
Send private message

Man on Monday I had to get a windows nt workstation hooked up to win 2008r2 server. Man can't believe that stuff is still around!





Hawkes Bay
8477 posts

Uber Geek
+1 received by user: 4

Mod Emeritus
Trusted
Lifetime subscriber

  Reply # 520792 14-Sep-2011 09:30
Send private message

Zeon: Man on Monday I had to get a windows nt workstation hooked up to win 2008r2 server. Man can't believe that stuff is still around!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 




Visit http://www.thecloud.net.nz for New Zealand based Hosted Exchange, Virtual Servers, Web Hosting, FTP Backup & more.
(1GB free FTP storage, or larger plans from $5.75)
 
 - Setup your own mailserver at home on Ubuntu Server - full step by step howto here.
 - Have you seen this: Nathan "KFC4LIFE" Dunn.


1873 posts

Uber Geek
+1 received by user: 262

Trusted

  Reply # 520815 14-Sep-2011 10:13
Send private message

Why does it have to run dos?

We run our CNC off an old XP machine, with a processor slower than my phone lol

gzt

9582 posts

Uber Geek
+1 received by user: 1400


  Reply # 520975 14-Sep-2011 14:25
Send private message

Not your only problem I'm sure but start here:

In your config.sys you have a line:
BUFFERS=30DEVICE=C:\NET\PROTMAN.DOS /I:C:\NET
. Is that a copy error? If not you should have two lines:

BUFFERS=30
DEVICE=C:\NET\PROTMAN.DOS /I:C:\NET

Is the other machine exactly the same model? Can you provide the config from there as well?

Do you get any errors during the boot and configuration loading process? I cannot recall how to boot msdos step by step or log the boot if I ever knew, I think it was a case of rapid alternate use of the pause/break button and spacebar to continue each step with a notepad and pen.

Also, what output do you get from the 'net start' command if you run that on the workstation after boot?



7 posts

Wannabe Geek


  Reply # 521172 14-Sep-2011 20:32
Send private message

That was a typo when it boots up i get the error 7361 : ipx or netbios must be running in order to load network services. The same as when i do net start.

The other machine has a different motherboard but still runs dos 6.22
Here are the files for it

Autoexec.bat      
C:\NET\net start ;
NET USE D:\\3dmill\from /YES /PERSISTENT:NO   
NET USE E:\\3dmill\sync /YES /PERSISTENT:NO
NET USE D:\\3dmill\from
NET USE E:\\3dmill\sync
LH C:\DOS\SHARE
NET SHARE C=C:\/YES /SAVESHARE=NO /FULL
@echo off
SET CAM=both
SET EDT=cnc7
; C:\nc\drivers\mouse.com /S10
cd\cnc7
if exist cpu7kb.com cpu7kb
cnc7m4

Config.sys  
   
DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS X=D000-D100 X=D000-D1FF
BUFFERS=30,0
FILES=30
DOS=UMB
LASTDRIVE=F
FCBS=4,0
DOS=HIGH
STACKS 0,0
;DEVICEHIGH /L:0;2,9424 /S =C:\DOS\INTERLNK.EXE
devicehigh=C:\NET\protman.dos /i:C:\NET
devicehigh=C:\NET\workgrp.sys
devicehigh=C:\NET\ne2000.dos

Protocol.ini[network.setup]
version=0x3100
netcard=ms$ne2clone,1,MS$NE2CLONE
transport=ms$netbeui,MS$NETBEUI
lana0=ms$ne2clone,1,ms$netbeui

[protman]
DriverName=PROTMAN$
PRIORITY=MS$NETBEUI

[MS$NE2CLONE]
DriverName=MS2000$
IOBASE=0x320
INTERRUPT=10

[MS$NETBEUI]
DriverName=netbeui$
SESSIONS=6
NCBS=12
BINDINGS=MS$NE2CLONE
LANABASE=0

gzt

9582 posts

Uber Geek
+1 received by user: 1400


  Reply # 521654 15-Sep-2011 20:02
Send private message

Is that the only error during config and autoexec? you really need to pause/resume at the right moment/s during boot to note them.

If you want a quick fix, you could just try running the same configuration files in the first machine. Remember to keep backups tho.



7 posts

Wannabe Geek


  Reply # 521923 16-Sep-2011 13:04
Send private message

Id already tryed that and i still got the same error. I got hold of a drivers disk for the machine 2 days ago and it the drivers are loading, net.exe is working but now its run out of memory.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon launches the International Shopping Experience in the Amazon Shopping App
Posted 19-Apr-2018 08:38


Spark New Zealand and TVNZ to bring coverage of Rugby World Cup 2019
Posted 16-Apr-2018 06:55


How Google can seize Microsoft Office crown
Posted 14-Apr-2018 11:08


How back office transformation drives IRD efficiency
Posted 12-Apr-2018 21:15


iPod laws in a smartphone world: will we ever get copyright right?
Posted 12-Apr-2018 21:13


Lightbox service using big data and analytics to learn more about customers
Posted 9-Apr-2018 12:11


111 mobile caller location extended to iOS
Posted 6-Apr-2018 13:50


Huawei announces the HUAWEI P20 series
Posted 29-Mar-2018 11:41


Symantec Internet Security Threat Report shows increased endpoint technology risks
Posted 26-Mar-2018 18:29


Spark switches on long-range IoT network across New Zealand
Posted 26-Mar-2018 18:22


Stuff Pix enters streaming video market
Posted 21-Mar-2018 09:18


Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47


Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25


New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48


Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.