Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


52 posts

Master Geek


Topic # 93924 1-Dec-2011 16:58
Send private message

I currently have a Linksys RV082 router providing failover connectivity to 2 Internet connections, one using a PPPoE wireless link, and the other using an ADSL connection in half bridge mode. The ADSL modem is failing (a Dynalink RTA1320 exhibiting the overheating problems outlined elsewhere in these forums) so after some research have replaced it with a Draytek Vigor 120. I can get the Draytek working correctly with a PPPoE connection from a laptop, obtaining the assigned fixed IP address from the ISP (Orcon), but nothing at all from the Linksys RV082.

The Linksys RV082 IP address is 192.168.1.250 (DHCP on)
I have tried the Draytek on both 192.168.1.2 (Dratek DHCP turned off) and 192.168.2.1 (Draytek DHCP turned on or off)
I have ticked the PPPoE Pass-through "For Wired LAN" box.


Any suggestions on what I might be missing? 

Create new topic
2970 posts

Uber Geek
+1 received by user: 288


  Reply # 552344 1-Dec-2011 17:12
Send private message

The RV082 IP of 192.168.1.250, is that the WAN port that the Draytek is connected to or is that the IP range of the local LAN?

I haven't ever used a dual wan router but I would assume that it would have three IP addresses.
One IP for the local LAN, one IP for WAN1 and one IP for WAN2.
Is that correct?
All IPs would need to be on different subnets otherwise it won't work.




341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 552367 1-Dec-2011 18:27
Send private message

Could you screenshot the connection's configuration in the Linksys?



52 posts

Master Geek


  Reply # 552400 1-Dec-2011 20:33
Send private message

The IP address 192.168.1.250 is the internal LAN address.  The WAN ports obtain their IP addresses from the respective ISPs (both are fixed IPs). When I connected the laptop directly to the Draytek using PPPoE it obtained the fixed IP address on the PPPoE network connection, but still had a 192.168.2.x address assigned to the LAN connection by the draytek DHCP server. 

I have included the current RV082 settings, but WAN2 would look similar to WAN1 (ie PPPoE settings) when the Draytek is attached.



2970 posts

Uber Geek
+1 received by user: 288


  Reply # 552407 1-Dec-2011 20:57
Send private message

I would disable DHCP on the draytek as it's not needed.
With the one I setup with PPPoE pass-through enabled I could not access it anymore via the IP address, it basically became invisible except to PPPoE requests..




2355 posts

Uber Geek
+1 received by user: 374

Trusted

  Reply # 552410 1-Dec-2011 21:06
Send private message

Try removing the Service Name of ICONZ as that will be the PPPoE concentrators name which is probably not ICONZ.

341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 552438 1-Dec-2011 22:40
Send private message

LennonNZ: Try removing the Service Name of ICONZ as that will be the PPPoE concentrators name which is probably not ICONZ.


This is one of the most common issues - Service Name should be left blank on the router connecting through the Vigor120.

Other than that I can't see anything wrong with that setup. If the Service Name thing doesn't help, feel free to give me a call during work hours (0800 ETHERNET, ask for Ed) or email me the logs from the router showing it failing to connect.



52 posts

Master Geek


  Reply # 552505 2-Dec-2011 08:52
Send private message

Thanks for the info. The service name was the problem. That would have been the last thing I would have thought of as the ICONZ service name has been altered a couple of times and has no effect on that connection. I removed Orcon from the WAN2 service name and every thing sprang to life!

341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 552561 2-Dec-2011 11:40
Send private message

aaristotle: Thanks for the info. The service name was the problem. That would have been the last thing I would have thought of as the ICONZ service name has been altered a couple of times and has no effect on that connection. I removed Orcon from the WAN2 service name and every thing sprang to life!


Yeah, ICONZ must be stripping the Service Name out at their end. I've got a bug report in to DrayTek requesting they do the same.

In the meantime I've added it to the HowTo article Smile

Let me know if you have any other issues!

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.