Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

stw



28 posts

Geek


Topic # 96248 23-Jan-2012 12:16
Send private message

Im just setting up a new router I got from telecom 2Wire router.

Its connected to the internet my Skype works fine but I had to manually put in telecoms DNS settings into my computer (Apple Mac) so I could browse the net.

My iPhone connects to the wife but the internet doesn't work!!

There seems to be a problem with the DNS settings on the router but when I log onto the router it appear to have the right DNS settings.

Has any had this same problem and how do I fix it?  I don't want to have to manually put in DNS setting on every computer.

 

Create new topic
1685 posts

Uber Geek
+1 received by user: 400

Lifetime subscriber

  Reply # 572376 23-Jan-2012 14:36
Send private message

Is there a problem with your DHCP (Dynamic Host Configuration Protocol) configuration? For example, it might be turned off at the router if more than one device can't connect to the Internet.

DHCP assigns an IP address to your computer/phone/ etc and assigns other network parameters including the DNS name servers.




Survival of the fittest • 68kg HP Color LaserJet behemoth • 38kg HP Color LaserJet giant • 82kg HP Netserver leviathan - Extinct 2015 • 61kg HP Netserver brontosaurus - Extinct 2010 • 32kg Compaq Proliant goliath - Extinct 2010 • 31kg 21" IBM CRT gargantua - Extinct 2010


krt

2 posts

Wannabe Geek


  Reply # 572391 23-Jan-2012 15:06
Send private message

hey I checked his settings, the router is faulty.

dhcp is working fine. these routers work out of the box. have done a factory reset and double checked that dncp is on, client gets dhcp address fine.

oddly enough, can see the router is picking up the correct DNS from Telecom
 Primary DNS: 202.27.158.40
Secondary DNS: 202.27.156.72

on the client can see via DHCP its using the routers IP for the DNS (192.168.1.254) but client cant resolve anything. if manually specify dns server on client e.g. 202.27.158.40 it works fine.

even tried manually specifying DNS on router but doesn't make any difference

new one is it the way 

stw



28 posts

Geek


  Reply # 573123 25-Jan-2012 11:18
Send private message

I got a brand new 2Wire router today and still have same problem!!!!



 

1984 posts

Uber Geek
+1 received by user: 133

Trusted

  Reply # 573290 25-Jan-2012 20:54
Send private message

Is the router supposed to allocate the 2wire.net domain with DHCP? Anyway, you might be able to find a setting for DNS proxy/forwarding that you can change.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

5 posts

Wannabe Geek


  Reply # 575993 1-Feb-2012 17:07
Send private message

+1   Exact same problem.  Can connect to net if I hard code the Telecom DNS settings but that doesn't work for iPhone and iPad.  The 2Wires is brand new out of the box.  Did a new router resolve the problem?

5 posts

Wannabe Geek


  Reply # 576676 3-Feb-2012 09:43
Send private message

Bump.....  anyone got any ideas?

18321 posts

Uber Geek
+1 received by user: 5246

Trusted
Lifetime subscriber

  Reply # 576680 3-Feb-2012 09:50
Send private message

Yes I had this problem with a customer, turned out to be a MTU (can't recall but it was set to something bigger than it should have been) problem, they couldn't fix it in the end and supplied an alternative brand for them.

5 posts

Wannabe Geek


  Reply # 576696 3-Feb-2012 10:34
Send private message

I read somewhere that changing the MTU to 1492 may fix it.  That makes no sense to me but your experience would seem to support an MTU issue.  I will look to change it and report back.  Any other thoughts much appreciated.  I guess plan B is to get Telecom to replace it.   Cheers...Andrew

5 posts

Wannabe Geek


  Reply # 577657 5-Feb-2012 21:04
Send private message

I'm due on site Tuesday to try and fix this issue. I have got things going in the meantime by changing the iPhone (and iPad) over to Static Addressing and adding Telecoms primary DNS IP Address. But this is not the way it should be and I'd really love to crack it rather than just admit defeat, blame Telecom and try and get a different brand router out of them. Any advice or ideas that I could try would be greatly appreciated.

5 posts

Wannabe Geek


  Reply # 582561 16-Feb-2012 21:26
Send private message

Anyone got any updates on this.  I'm assuming replacing the router is still the best plan.

28 posts

Geek

Trusted

  Reply # 638104 9-Jun-2012 01:32
Send private message

Replacing the router best plan if you're using Macs...

According to the Telecom broadband helpdesk it's a fault in the latest 2Wire router firmware that causes DNS problems with Macs. They suggested the router be swapped for another Telecom router (Technica (?) or Thompson).

I experienced exactly the same issues with a 2Wire ADSL wireless router supplied by Telecom for testing.

- The router connected to the internet and successfully received valid IP and DNS settings
- All devices connected to the router via wifi and received valid IP and DNS settings (pointing to router)
- MacBook Pro and iPhones could not connect to the internet but iMac could (all on wifi)
- MacBook Pro could connect to internet when Mac DNS set to OpenDNS (using DNSCrypt)

Conclusion: DNS requests from MacBook Pros and iPhones are passed to router but fail to reach external DNS. Telecom have observed this fault with Macs since the latest 2Wire firmware update (they mentioned that this fault may not be known by all helpdesk staff).

krt

2 posts

Wannabe Geek


Reply # 638113 9-Jun-2012 07:17
Send private message

I found a fix to this awhile ago. Laughing

The problem is the Telecom 2Wire gateway doesnt seem to work as a DNS server for Apple Mac computers or even iPhone, iPad etc.

You can login to the modem and configure it to provide the Telecom DNS servers directly to the client.

This is how you fix it:

Go to modem webpage: http://192.168.1.254
Click Settings
Select Link Configuration
The default password: admin

Now go down to DNS and adjust it to "Manually Specify DNS information"
Primary server: 202.27.158.40
Secondary server: 202.27.156.72

Save it and your done!


28 posts

Geek

Trusted

  Reply # 638135 9-Jun-2012 09:34
Send private message

Thanks for that workaround. I can't confirm it as the client has returned the router but hopefully it works for someone with this issue.

N.B. 1) The router does configure the correct Telecom DNS values automatically. 2) I did try manually configuring the router to point to OpenDNS but it didn't appear to fix the issue.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.