I bought a RoyalTek Bluetooth 2100 GPS receiver of trademe - I have a Dell Axim x51v doing not much at the moment and wanted to make an el cheapo GPS solution.




The manual is not exactly the finest example of Queen's English, but from what I can gather, the device seems to work - it will gain a GPS fix (flashing green light becomes solid), and seems to be available for bluetooth discovery (solid blue light), but I cannot discover the GPS receiver no matter what I do. I have tried searching for the GPS receiver using the above PDA, but also a Macbook and a cell phone (Nokia E60), none of which seem to be able to find it (and they can all find each other).




I have tried quite a few different options (GPS fix, no GPS fix, plugged in, not plugged in, leaving battery out for about 24 hours) but no joy.




I have tried contacting the TM seller, who said it worked fine for him with an HP PDA.




Any ideas as to why it does not seem to be working for me? I cannot find any info on the web about this sort of problem. Or even how to perform a hard/factory reset?




Or a trademe lemon? Not even heavy enough to use as a paperweight...