59 days ago, I posted an issue with getting my tp link modem to run as ADSL2+ speeds. This issue is resolved. The issue was caused by the Airport router which I was using to connect the modem. For some reason, while the modem was attempting to negotiate the ATM, something on the network (probably to be the router as everything else on the network was off but maybe the iPad) was cause the handshaking to stall and fall. So, if setting up the tp link in future, direct connect to the modem only. Lesson learned.