Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Lifetime subscriber

Topic # 29809 20-Jan-2009 11:19
Send private message

I haven't been able to find any info on why this happens, nor any setting I could change to make this work.
I have an internal Exchange server named exchange-nz1.domain.co.nz.
I have opened external access to this server for Outlook clients on owa.domain.co.nz.
When setting up an account, Outlook 2007 tries to find the server and fills the server information using exchange-nz1.domain.co.nz. I manually set the server name to be owa.domain.co.nz but when it saves the information, it falls back to exchange-nz1.domain.co.nz.

DNS records have been set to point owa.domain.co.nz to the server's IP address (A record), so I have no idea how it finds exchange-nz1.


Anyone knows how this works? Or how to turn it off?




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

Create new topic
BDFL - Memuneh
61486 posts

Uber Geek
+1 received by user: 12208

Administrator
Trusted
Geekzone
Lifetime subscriber



Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Lifetime subscriber

  Reply # 190752 20-Jan-2009 11:51
Send private message

freitasm: Probably this the Computer Name?

Not sure I'm following you: you mean Outlook uses the computer name instead of the manually entered domain I just put in? How do I turn that off?




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

BDFL - Memuneh
61486 posts

Uber Geek
+1 received by user: 12208

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 190758 20-Jan-2009 12:00
Send private message

magu:
freitasm: Probably this the Computer Name?

Not sure I'm following you: you mean Outlook uses the computer name instead of the manually entered domain I just put in? How do I turn that off?


On the server, right-click Computer | Properties | Computer Name.






Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Lifetime subscriber

  Reply # 190777 20-Jan-2009 13:16
Send private message

The computer name is exchange-nz1.domain.co.nz.




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

BDFL - Memuneh
61486 posts

Uber Geek
+1 received by user: 12208

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 190778 20-Jan-2009 13:18
Send private message


Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Lifetime subscriber

  Reply # 190783 20-Jan-2009 13:31
Send private message

The problem is that this Exchange server name is not available outside the office, but owa.domain.co.nz is. If I setup Outlook to use owa.domain.co.nz from outside the office, it works fine (both inside and outside), but if Outlook keeps falling back to the server name, I can't get users to use Outlook at all if not on a VPN.
I think the issue here is Outlook not keeping its server settings as I entered them.




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

BDFL - Memuneh
61486 posts

Uber Geek
+1 received by user: 12208

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 190786 20-Jan-2009 13:44
Send private message

Don't worry about the server name. What you need is to configure Outlook to access via a HTTP(s) proxy that will be your server:





The configuration here shows I am using https://mail.geekzone.co.nz to access my Exchange Server, but the internal server is completely different - is actually an old address used with dyndns.org from the times I used to run it from home. When I look on my Outlook configuration the server name is still the old one but all works fine because I am using the actual server to access it.






Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Lifetime subscriber

  Reply # 190788 20-Jan-2009 13:46
Send private message

Aha!

Is there a way to push this setting through GPOs?




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

BDFL - Memuneh
61486 posts

Uber Geek
+1 received by user: 12208

Administrator
Trusted
Geekzone
Lifetime subscriber

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.